summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-23 07:39:28 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-24 05:37:37 +0200
commit9b64c434c3fac7e1a734b486c49987c2df7fea09 (patch)
treefae58d6267d831c540dd5eea5f12664e10cc3ba3 /dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild
parentdev-ruby/acts_as_list: cleanup (diff)
downloadgentoo-9b64c434c3fac7e1a734b486c49987c2df7fea09.tar.gz
gentoo-9b64c434c3fac7e1a734b486c49987c2df7fea09.tar.bz2
gentoo-9b64c434c3fac7e1a734b486c49987c2df7fea09.zip
dev-ruby/acts_as_list: add 0.8.2
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild')
-rw-r--r--dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild b/dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild
new file mode 100644
index 000000000000..95ad760154ef
--- /dev/null
+++ b/dev-ruby/acts_as_list/acts_as_list-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+DESCRIPTION="Capabilities for sorting and reordering a number of objects in a list"
+HOMEPAGE="https://github.com/swanandp/acts_as_list"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~x86-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activerecord-3:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ dev-ruby/activerecord[sqlite]
+ )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -i -e '1,9 s:^:#:' test/helper.rb || die
+ sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/github_changelog/,$ s:^:#:' Rakefile || die
+}