summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-30 08:07:54 +0200
committerHans de Graaff <graaff@gentoo.org>2017-03-30 08:07:54 +0200
commit79cb0eb2b4a149c880ab0fd9b423fedbb89a5a4a (patch)
treefa2f9560e1acf558f1cf827efd1beb1d2e0120b0 /dev-ruby/addressable
parentdev-ruby/addressable: cleanup (diff)
downloadgentoo-79cb0eb2b4a149c880ab0fd9b423fedbb89a5a4a.tar.gz
gentoo-79cb0eb2b4a149c880ab0fd9b423fedbb89a5a4a.tar.bz2
gentoo-79cb0eb2b4a149c880ab0fd9b423fedbb89a5a4a.zip
dev-ruby/addressable: add 2.5.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/addressable')
-rw-r--r--dev-ruby/addressable/Manifest1
-rw-r--r--dev-ruby/addressable/addressable-2.5.1.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/addressable/Manifest b/dev-ruby/addressable/Manifest
index 89dc1ce4a2a7..968f0eb4dacf 100644
--- a/dev-ruby/addressable/Manifest
+++ b/dev-ruby/addressable/Manifest
@@ -1,3 +1,4 @@
DIST addressable-2.3.6.gem 98304 SHA256 e822c28133d151d450778bbcf1f6e7742d4c3aba54498eb0da33d80a3990ee8c SHA512 26a2d754397a5e46bc22ea9755d1c1a1b9f993e38fcf9b0a6133ea6d0aa7bdc0fe6bfe83bc39991e3b258fa3122e44bbd0b0758026be02af2a70ffef96d0dfa4 WHIRLPOOL 19ef0436df04172ca5dd9811d75616e069871476df879c10bc711e9db084636ca6edebed7500707d9409d6bd9041ece431609a7e4b2e42121a7cce6989bf5964
DIST addressable-2.4.0.gem 102400 SHA256 7abfff765571b0a73549c9a9d2f7e143979cd0c252f7fa4c81e7102a973ef656 SHA512 b81fa48e7c4188827c03ac93960b6fd6fb9f5a438f5243cddea39d6820ef756ee7c0086ec330dc4a3538008b3b254757af7d30248624127649cc006a2793eda8 WHIRLPOOL 6f245a158eb13b69add13a024421e88c8b4b5344f11b74bd95d9967fb265889e0123c63c041660d74994d08bcc18c345a34e91c45b20aef40ee5cbc5abfd80b7
DIST addressable-2.5.0.gem 103424 SHA256 bc5bf921b39640675fbb3484cdb45e4241b4c88d8d5a7d85a3985424ad02b9c8 SHA512 188689b99b4d83756844592ad697e8e20d27540e5c6bc758934f75592adddf7ef98ca5c9ad0d407d3dda9298496c18a661eda8a52776128ff089fd4f315fdbe1 WHIRLPOOL 1128dbcc7cb2ef290e329b0fb0d6cf8786ec1d0de104230d4642fb34b2b1a5c4d7ae1abc8b83aa4c81135a5725489aa4c3b1393ea7325207acceb63c35b1806d
+DIST addressable-2.5.1.gem 103424 SHA256 b09603b313a94fa3674d8fbaae77cc7c778e9d3cde5fea3b7c1fe447941818c5 SHA512 ae7232dc6cbd1aa6405135c7916697a93286fcb223b14e2c30b5897aed6fe32529c94bfb84154e0cead5af9a282cc89442cbd3249b68abd7ffd67b6c4599bff3 WHIRLPOOL aeebce579a1f2dacd8672224a0c39e1ea4c9c26e1d5ef4aa3f84726df94b1f305e6cd4ad3569dd602997ccc9ad225a69c59e2f519a34d5856ba13fa20a818b21
diff --git a/dev-ruby/addressable/addressable-2.5.1.ebuild b/dev-ruby/addressable/addressable-2.5.1.ebuild
new file mode 100644
index 000000000000..1c8822ee6917
--- /dev/null
+++ b/dev-ruby/addressable/addressable-2.5.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
+HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
+
+LICENSE="Apache-2.0"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/public_suffix-2.0.2:2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
+
+all_ruby_prepare() {
+ # Remove spec-related tasks so that we don't need to require rspec
+ # just to build the documentation, bug 383611.
+ sed -i -e '/spectask/d' Rakefile || die
+ rm -f tasks/rspec.rake || die
+ sed -i -e '/bundler/ s:^:#:' \
+ -e '/^begin/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Remove specs requiring network connectivity
+ rm -f spec/addressable/net_http_compat_spec.rb || die
+
+ # Remove spec that tests against an unreleased github fork
+ rm -f spec/addressable/rack_mount_compat_spec.rb || die
+}