summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-09 07:43:17 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-10 07:19:15 +0100
commit7446081521638538fe58ea449c4eb9c5fa086a25 (patch)
tree7610ce34e6e4c0e0a4c84fa8b1cb7e2d65cb0e5d /dev-ruby/allison
parentsys-apps/coreutils: give hint for libgmp location in cross (diff)
downloadgentoo-7446081521638538fe58ea449c4eb9c5fa086a25.tar.gz
gentoo-7446081521638538fe58ea449c4eb9c5fa086a25.tar.bz2
gentoo-7446081521638538fe58ea449c4eb9c5fa086a25.zip
dev-ruby/allison: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/allison')
-rw-r--r--dev-ruby/allison/allison-2.0.3-r4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/allison/allison-2.0.3-r4.ebuild b/dev-ruby/allison/allison-2.0.3-r4.ebuild
new file mode 100644
index 000000000000..0ce94df3be22
--- /dev/null
+++ b/dev-ruby/allison/allison-2.0.3-r4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_EXTRAINSTALL="cache"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A modern, pretty RDoc template"
+HOMEPAGE="https://fauna.github.com/fauna/allison/files/README.html"
+
+LICENSE="AFL-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-solaris"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r contrib
+}