summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-25 06:23:58 +0000
committerSam James <sam@gentoo.org>2023-03-25 07:09:10 +0000
commitaafb07850a96e3454336369b67e8b08a46aa8239 (patch)
tree748e2c8d37da5b8a0d039176cb7f64f67c5d1193 /dev-ruby/ansi
parentdev-ruby/ruby-rc4: enable ruby32 (diff)
downloadgentoo-aafb07850a96e3454336369b67e8b08a46aa8239.tar.gz
gentoo-aafb07850a96e3454336369b67e8b08a46aa8239.tar.bz2
gentoo-aafb07850a96e3454336369b67e8b08a46aa8239.zip
dev-ruby/ansi: partly wire up tests, still restricted
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/ansi')
-rw-r--r--dev-ruby/ansi/ansi-1.5.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ruby/ansi/ansi-1.5.0-r1.ebuild b/dev-ruby/ansi/ansi-1.5.0-r1.ebuild
index 6842446df0a1..a72fb394da1a 100644
--- a/dev-ruby/ansi/ansi-1.5.0-r1.ebuild
+++ b/dev-ruby/ansi/ansi-1.5.0-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+USE_RUBY="ruby27 ruby30 ruby31"
RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -20,3 +21,7 @@ IUSE=""
# Tests cause circular dependencies with dev-ruby/qed & dev-ruby/rubytest
RESTRICT="test"
+
+each_ruby_test() {
+ ${RUBY} -S rubytest -Ilib -Itest test/ || die 'tests failed'
+}