summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/archive-tar-minitar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/archive-tar-minitar')
-rw-r--r--dev-ruby/archive-tar-minitar/Manifest1
-rw-r--r--dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild47
-rw-r--r--dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r2.ebuild47
-rw-r--r--dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.2-gentoo.patch20
-rw-r--r--dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.3-pipes.patch44
-rw-r--r--dev-ruby/archive-tar-minitar/metadata.xml9
6 files changed, 168 insertions, 0 deletions
diff --git a/dev-ruby/archive-tar-minitar/Manifest b/dev-ruby/archive-tar-minitar/Manifest
new file mode 100644
index 000000000000..c8b115c1b047
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/Manifest
@@ -0,0 +1 @@
+DIST minitar-0.5.4.gem 23552 SHA256 6aae3dafcf83b5d3f4f2485edbca202a0ae054ba2e3b204c24cc07dcaa93edee SHA512 e629e48b12f2dac1229ee1fd1f6fa5b5b7707d7a0298f90778767b1456b78f26fadb37e90e44bba2fd60a2541544f47cb430d19c87abc1a87c3be6843fbcb5aa WHIRLPOOL c6df959de613396168212c9b92b058b66ccca95efb16f40c40ebaf89eb20776b11a07f6d4b9c53c31234d6b33bccca573312d68c206734e10be00c5a1d4b5c86
diff --git a/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild
new file mode 100644
index 000000000000..a540edc3241c
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+# We don't use RUBY_FAKEGEM_NAME here since for now we want to keep the
+# same gem name.
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides POSIX tarchive management from Ruby programs"
+HOMEPAGE="https://github.com/halostatue/minitar"
+SRC_URI="mirror://rubygems/minitar-${PV}.gem"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.5.2-gentoo.patch
+ ${PN}-0.5.3-pipes.patch
+)
+
+all_ruby_prepare() {
+ # ignore faulty metadata
+ rm -f ../metadata || die
+
+ # Fix tests by using ruby19+ compatible code.
+ # Avoid failing tests.
+ # https://github.com/halostatue/minitar/issues/9
+ sed -i -e '52 s/x\[0\]/x[0].ord/' \
+ -e '/test_each_works/,/^ end/ s:^:#:' \
+ -e '/test_extract_entry_works/,/^ end/ s:^:#:' tests/tc_tar.rb || die
+
+}
+
+each_ruby_test() {
+ ${RUBY} -Itests -Ctests testall.rb || die
+}
diff --git a/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r2.ebuild b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r2.ebuild
new file mode 100644
index 000000000000..8cdc9aab3720
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/archive-tar-minitar-0.5.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+# We don't use RUBY_FAKEGEM_NAME here since for now we want to keep the
+# same gem name.
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides POSIX tarchive management from Ruby programs"
+HOMEPAGE="https://github.com/halostatue/minitar"
+SRC_URI="mirror://rubygems/minitar-${PV}.gem"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.5.2-gentoo.patch
+ ${PN}-0.5.3-pipes.patch
+)
+
+all_ruby_prepare() {
+ # ignore faulty metadata
+ rm -f ../metadata || die
+
+ # Fix tests by using ruby19+ compatible code.
+ # Avoid failing tests.
+ # https://github.com/halostatue/minitar/issues/9
+ sed -i -e '52 s/x\[0\]/x[0].ord/' \
+ -e '/test_each_works/,/^ end/ s:^:#:' \
+ -e '/test_extract_entry_works/,/^ end/ s:^:#:' tests/tc_tar.rb || die
+
+}
+
+each_ruby_test() {
+ ${RUBY} -Itests -Ctests testall.rb || die
+}
diff --git a/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.2-gentoo.patch b/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.2-gentoo.patch
new file mode 100644
index 000000000000..789637c68b97
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.2-gentoo.patch
@@ -0,0 +1,20 @@
+Index: archive-tar-minitar-0.5.2/bin/minitar
+===================================================================
+--- archive-tar-minitar-0.5.2.orig/bin/minitar
++++ archive-tar-minitar-0.5.2/bin/minitar
+@@ -12,15 +12,6 @@
+ # $Id$
+ #++
+
+- # 1) Try to load Archive::Tar::Minitar from the gem.
+- # 2) Try to load Archive::Tar::Minitar from $LOAD_PATH.
+-begin
+- require 'rubygems'
+- require_gem 'archive-tar-minitar', '= 0.5.2'
+-rescue LoadError
+- nil
+-end
+-
+ require 'archive/tar/minitar'
+ require 'archive/tar/minitar/command'
+
diff --git a/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.3-pipes.patch b/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.3-pipes.patch
new file mode 100644
index 000000000000..27b626869f48
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/files/archive-tar-minitar-0.5.3-pipes.patch
@@ -0,0 +1,44 @@
+Index: minitar-0.5.3/lib/archive/tar/minitar.rb
+===================================================================
+--- minitar-0.5.3.orig/lib/archive/tar/minitar.rb
++++ minitar-0.5.3/lib/archive/tar/minitar.rb
+@@ -486,7 +486,11 @@ module Archive::Tar::Minitar
+ @devminor = header.devminor
+ @prefix = header.prefix
+ @read = 0
+- @orig_pos = @io.pos
++ begin
++ @orig_pos = @io.pos
++ rescue Errno::ESPIPE
++ @orig_pos = 0
++ end
+ end
+
+ # Reads +len+ bytes (or all remaining data) from the entry. Returns
+@@ -585,7 +589,11 @@ module Archive::Tar::Minitar
+ # Creates and returns a new Reader object.
+ def initialize(anIO)
+ @io = anIO
+- @init_pos = anIO.pos
++ begin
++ @init_pos = @io.pos
++ rescue Errno::ESPIPE
++ @init_pos = 0
++ end
+ end
+
+ # Iterates through each entry in the data stream.
+@@ -621,10 +629,10 @@ module Archive::Tar::Minitar
+
+ skip = (512 - (size % 512)) % 512
+
+- if @io.respond_to?(:seek)
+- # avoid reading...
++ begin
++ # avoid reading...
+ @io.seek(size - entry.bytes_read, IO::SEEK_CUR)
+- else
++ rescue Errno::ESPIPE, NoMethodError
+ pending = size - entry.bytes_read
+ while pending > 0
+ bread = @io.read([pending, 4096].min).size
diff --git a/dev-ruby/archive-tar-minitar/metadata.xml b/dev-ruby/archive-tar-minitar/metadata.xml
new file mode 100644
index 000000000000..344693a25b1a
--- /dev/null
+++ b/dev-ruby/archive-tar-minitar/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="rubyforge">ruwiki</remote-id>
+ <remote-id type="github">halostatue/minitar</remote-id>
+ </upstream>
+</pkgmetadata>