summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-28 07:30:11 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-28 07:51:44 +0100
commit9883714a59da4470ffebbfebeae19bbd2641a7da (patch)
treecca7dbb0825bdbfb487da3aa6532374b5d79e933 /dev-ruby/asciimath/asciimath-1.0.2.ebuild
parentversion bump (diff)
downloadgentoo-9883714a59da4470ffebbfebeae19bbd2641a7da.tar.gz
gentoo-9883714a59da4470ffebbfebeae19bbd2641a7da.tar.bz2
gentoo-9883714a59da4470ffebbfebeae19bbd2641a7da.zip
dev-ruby/asciimath: initial import of 1.0.2
New dependency for dev-ruby/asciidoctor Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/asciimath/asciimath-1.0.2.ebuild')
-rw-r--r--dev-ruby/asciimath/asciimath-1.0.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/asciimath/asciimath-1.0.2.ebuild b/dev-ruby/asciimath/asciimath-1.0.2.ebuild
new file mode 100644
index 000000000000..9ae5eddf57c5
--- /dev/null
+++ b/dev-ruby/asciimath/asciimath-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby AsciiMath parsing and conversion library"
+HOMEPAGE="https://github.com/pepijnve/asciimath"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_test() {
+ RSPEC_VERSION=3 ruby-ng_rspec test
+}