summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-08 07:45:43 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-08 07:45:43 +0200
commit2bbc4164f78ed1a89bd4600a3a9121e606c338e5 (patch)
treefcc890dd2499cf5f2f65f7d13b6ca036af13f978 /dev-ruby/asciimath
parentdev-ruby/asciidoctor-diagram: update EAPI 7 -> 8, ruby30 (diff)
downloadgentoo-2bbc4164f78ed1a89bd4600a3a9121e606c338e5.tar.gz
gentoo-2bbc4164f78ed1a89bd4600a3a9121e606c338e5.tar.bz2
gentoo-2bbc4164f78ed1a89bd4600a3a9121e606c338e5.zip
dev-ruby/asciimath: add 2.0.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/asciimath')
-rw-r--r--dev-ruby/asciimath/Manifest1
-rw-r--r--dev-ruby/asciimath/asciimath-2.0.4.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/asciimath/Manifest b/dev-ruby/asciimath/Manifest
index cfb397c6d45a..b97e829a4f92 100644
--- a/dev-ruby/asciimath/Manifest
+++ b/dev-ruby/asciimath/Manifest
@@ -3,3 +3,4 @@ DIST asciimath-2.0.0.gem 57344 BLAKE2B 18cb2ca27a626bbb241768d070c47c981ae1f3a62
DIST asciimath-2.0.1.gem 58880 BLAKE2B 6c17698f6515468c1c0b17408968f492a40a90cbec5184e78da8c9b9c23f2a6887f4d8ed1c99a68ed36489d27187dd73dc6ce992efc3ce144091131e36bc5e40 SHA512 e8c63e5f6035189460ac4975bb0471ffa418ba139ab806ae46badb74c1164d2852aef3aa799a0713a01486cea5c6087add6115ea22908bf3b70d1ab5fe339768
DIST asciimath-2.0.2.gem 59904 BLAKE2B 2a8d57a606412be75ef047b5af29acb519b05026b12c6b691eab0630190706e00d1d8d65101d4397321191ad6d2c8f9e359e25994dd17302ff2692ebaa025a91 SHA512 53f573a9d7b01eded3c951b42a8353716679c189edd68129c49cdf0a719316f26d39ccf2704ae24c22dd64770bb8337553aa32d4f240bf1e249133ca95d849a8
DIST asciimath-2.0.3.gem 59392 BLAKE2B 7d1d373c5d80172e88ba5737ea2244c384f274c200fed2104b23e76b6615f5bc987e14acb5c8d9088069f590eed5c645a2f51338540197a2ef9c44696f704488 SHA512 748c8ff121190470299c1e04100e063fd7352a0adaeda160a235d1f0f0ccb02108274ffe8ab4f1f54b07eb750d637e26f2efb6aac12d3389dafe1c00be103f4c
+DIST asciimath-2.0.4.gem 60416 BLAKE2B 9a5d6bf967962d37e620d0b49204ba8dafadf65e95a613924c7c169fee98f00203861fbbb1c06db1ee833e401f9a2141566dc693237e1cb7e797e639c63dccfa SHA512 28ab7fd7f43320112c0e7166fb2a6ef269eb91314940deb88606443bec055792cf3c49bc2d9b75c1e5ee5690c3071e66f15f817c4539fc6246da7a8d792f1803
diff --git a/dev-ruby/asciimath/asciimath-2.0.4.ebuild b/dev-ruby/asciimath/asciimath-2.0.4.ebuild
new file mode 100644
index 000000000000..505bbab1dbf1
--- /dev/null
+++ b/dev-ruby/asciimath/asciimath-2.0.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby AsciiMath parsing and conversion library"
+HOMEPAGE="https://github.com/pepijnve/asciimath"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/nokogiri )"