summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-09 08:10:07 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-09 08:38:34 +0100
commit678b69c0312d21b6011673b86875e3fb68a39fe1 (patch)
treea99b9b48fc6e08410e9b79a8d7837c3700022288 /dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild
parenteclass/ruby-fakegem.eclass: fix warning about compressed docs (diff)
downloadgentoo-678b69c0312d21b6011673b86875e3fb68a39fe1.tar.gz
gentoo-678b69c0312d21b6011673b86875e3fb68a39fe1.tar.bz2
gentoo-678b69c0312d21b6011673b86875e3fb68a39fe1.zip
dev-ruby/autoprefixer-rails: add 9.4.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild
new file mode 100644
index 000000000000..5c7bdefdb192
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-9.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}