summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-04-01 07:21:12 +0200
committerHans de Graaff <graaff@gentoo.org>2022-04-02 07:56:14 +0200
commit7a4c74d21f3f60940764d1898ed9f695479502cf (patch)
tree1ed24a10b7aa6607912021eef0faf1340f0b6422 /dev-ruby/autoprefixer-rails
parentdev-ruby/windows_error: add 0.1.4 (diff)
downloadgentoo-7a4c74d21f3f60940764d1898ed9f695479502cf.tar.gz
gentoo-7a4c74d21f3f60940764d1898ed9f695479502cf.tar.bz2
gentoo-7a4c74d21f3f60940764d1898ed9f695479502cf.zip
dev-ruby/autoprefixer-rails: add 10.4.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/autoprefixer-rails')
-rw-r--r--dev-ruby/autoprefixer-rails/Manifest1
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/Manifest b/dev-ruby/autoprefixer-rails/Manifest
index ea2c4d25be7c..018f69727b52 100644
--- a/dev-ruby/autoprefixer-rails/Manifest
+++ b/dev-ruby/autoprefixer-rails/Manifest
@@ -1,2 +1,3 @@
DIST autoprefixer-rails-10.3.1.0.tar.gz 1357327 BLAKE2B 2071b3a9c5848e06695e32445224f6e101481fac0ca73a23b86d138bfada9f7339bd51031f121ab8b0f614d2ea1ec386cb81dbbcf8f728075b12ff2393c0c8b5 SHA512 fff90cad950228e9d3b61259f26bee26b2fe3cd87557ed81f1235630357204e3cf9ce6cc9439551727d4d62d27f3510c8c2683ab12b05ad11549945f741e5db5
+DIST autoprefixer-rails-10.4.2.0.tar.gz 1368753 BLAKE2B b5c9374f6161f9f13f78404788cdba60d88f50f68f909cead6cb5389a4f26f05cdd20925cf91d9a0b01af0ce14929b11d69f85a1ce8493c660c50c6032460a0c SHA512 00303b7dec4b261b2d3ffa72ebdfea2883cb473df3f8149853b0d2fcb5c2e48d63e24a17604619289893d0472afe237f1dc13710d2c7c3528067c143789abf61
DIST autoprefixer-rails-9.8.6.5.gem 231936 BLAKE2B 7c702f5484f9aa2318408fb8c5c8866ccf9d3565d3282e43279b9bea875ac3610b26c0ec302b2bed0779dcd46eca12badaa16faba1046585cddcfa3e8b22b51c SHA512 6b7281661fcaf0c17ee258a321f8d18664f2f305172719f76fe1f3ef6b04fa1460c7102946e95153df7ecf5c3ade3bfc8c22d302927f2e2183ef3b0f3ef8d623
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.2.0.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.2.0.ebuild
new file mode 100644
index 000000000000..35e6cfaec0ff
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="autoprefixer-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+SRC_URI="https://github.com/ai/autoprefixer-rails/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/ s:^:#:" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ rm -f spec/rails_spec.rb || die
+}