summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/awesome_print
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/awesome_print')
-rw-r--r--dev-ruby/awesome_print/Manifest2
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.2.0-r2.ebuild21
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.6.1.ebuild21
-rw-r--r--dev-ruby/awesome_print/metadata.xml8
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/awesome_print/Manifest b/dev-ruby/awesome_print/Manifest
new file mode 100644
index 000000000000..d2a308f265b2
--- /dev/null
+++ b/dev-ruby/awesome_print/Manifest
@@ -0,0 +1,2 @@
+DIST awesome_print-1.2.0.gem 29184 SHA256 f9fb1d1bafddc4739266c68f3a043e409716a620aea937d54d1ae07c278305cd SHA512 10e1d77ceb0b05aa9b0f12911c24ab63d20a3c88f9fbace518562e7e6de21f6db5dbe75fc0b2c50fa244a33f08cba920d48dc04069ac740394200a1d695e2f4f WHIRLPOOL 1de1eecbfd2e5e3f03b69a0b6d4afd130fad59b22807f1a8d9f1416fd946a574f23bfc59f8391975e9d10770c9530aba48caca0ed137c0bdaaf2a4a50a6a8b9d
+DIST awesome_print-1.6.1.gem 32256 SHA256 0d8be8d9b270b900a337356cb9453ffdaf219d29902f14bbe4f120ecfdd38fef SHA512 394f5011d45f1daca77215e585d50c8505a63498b982aae32b206b99051fc27b903135fdb62976d9aeb4dfa80f5d6980b55c7fbe0fdc75feb979fd3b3b935c92 WHIRLPOOL 9d6c5f8fe60e3ba7ebbc16c5bcaf91337d2142d4846b490c75185c905ada1dd6f76fbd8f73a859bdeef91542ad3623758cfaa029d1b303dfc02d9b964199bc40
diff --git a/dev-ruby/awesome_print/awesome_print-1.2.0-r2.ebuild b/dev-ruby/awesome_print/awesome_print-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..e7e767de9023
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.2.0-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library that pretty prints Ruby objects in full color with proper indentation"
+HOMEPAGE="http://github.com/michaeldv/awesome_print"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
diff --git a/dev-ruby/awesome_print/awesome_print-1.6.1.ebuild b/dev-ruby/awesome_print/awesome_print-1.6.1.ebuild
new file mode 100644
index 000000000000..6cb8d9c25d98
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library that pretty prints Ruby objects in full color with proper indentation"
+HOMEPAGE="https://github.com/michaeldv/awesome_print"
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
diff --git a/dev-ruby/awesome_print/metadata.xml b/dev-ruby/awesome_print/metadata.xml
new file mode 100644
index 000000000000..eed93068e38f
--- /dev/null
+++ b/dev-ruby/awesome_print/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">michaeldv/awesome_print</remote-id>
+ </upstream>
+</pkgmetadata>