summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-17 11:25:29 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-17 11:25:29 +0200
commit1f4844a7ef6519394e890b232e37bdbc0adf3dac (patch)
tree05eeb474612b9191c94e2a68cfcf701a1929a1b0 /dev-ruby/aws-s3
parentdev-ruby/aws-s3: add ruby22, ruby23 (diff)
downloadgentoo-1f4844a7ef6519394e890b232e37bdbc0adf3dac.tar.gz
gentoo-1f4844a7ef6519394e890b232e37bdbc0adf3dac.tar.bz2
gentoo-1f4844a7ef6519394e890b232e37bdbc0adf3dac.zip
dev-ruby/aws-s3: avoid test that require network access, fixing bug 339324
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/aws-s3')
-rw-r--r--dev-ruby/aws-s3/aws-s3-0.6.3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
index 80d9b628570d..ed5224097140 100644
--- a/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
+++ b/dev-ruby/aws-s3/aws-s3-0.6.3.ebuild
@@ -33,6 +33,13 @@ RUBY_PATCHES=(
${P}+ruby19.patch
)
+all_ruby_prepare() {
+ # Avoid tests requiring network access, bug 339324
+ sed -i -e '/test_request_only_escapes_the_path_the_first_time_it_runs_and_not_subsequent_times/,/^ end/ s:^:#:' \
+ -e '/test_if_request_has_no_body_then_the_content_length_is_set_to_zero/,/^ end/ s:^:#:' \
+ test/connection_test.rb || die
+}
+
each_ruby_test() {
${RUBY} -I. -e "Dir['test/*_test.rb'].each {|f| require f }" || die
}