summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-12-26 08:18:56 +0100
committerHans de Graaff <graaff@gentoo.org>2019-12-26 08:19:11 +0100
commit85e9a084ee583715216aa410e6b74f66a550484b (patch)
tree8b462ec25bc2f32b6bd0b245dee00082effb4514 /dev-ruby/bundler
parentmedia-plugins/vdr-undelete: QA, missing newline fixed (diff)
downloadgentoo-85e9a084ee583715216aa410e6b74f66a550484b.tar.gz
gentoo-85e9a084ee583715216aa410e6b74f66a550484b.tar.bz2
gentoo-85e9a084ee583715216aa410e6b74f66a550484b.zip
dev-ruby/bundler: add 2.1.2
Also add a new 1.17.3-r1 revision to avoid file collisions on binstubs when both versions must be installed. Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/Manifest1
-rw-r--r--dev-ruby/bundler/bundler-1.17.3-r1.ebuild34
-rw-r--r--dev-ruby/bundler/bundler-2.1.2.ebuild32
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/bundler/Manifest b/dev-ruby/bundler/Manifest
index b69b3e34dfb3..d639f5ec4045 100644
--- a/dev-ruby/bundler/Manifest
+++ b/dev-ruby/bundler/Manifest
@@ -1 +1,2 @@
DIST bundler-1.17.3.gem 364032 BLAKE2B 81e097156a593e4ec85a2353aa6c62143d9aad120c22c5f76423c6c5f4e4d33206c8ef41c64e54ea53eb610a0d865beba19d3c033e8f65913564963319bb523f SHA512 658de4228bc12fa5ca6ce335f76fff773f64da9f3d12f5097b4fd28d4c4f4d2a5bf12dce761b3d95432c5ea6a5aafae895df87c26660a4567db8b682aff48c02
+DIST bundler-2.1.2.gem 396800 BLAKE2B 20540af4873f968412ddec542379a97b200d86a66b5e69ff9f2f57140063e49dd2ee52ed03e2fbaa1a8da8a3e12d0d4d2e3468031afdaee09a6aeed9910aeb60 SHA512 2a3b42fa2c6f40998c900eaf9d81d6417970f3daa572e4f1c5cc954fd8ce1e3cacbda0dc9b77d44b2fa756cfb1e72838ef3edee1812881198bbe8c946017e22b
diff --git a/dev-ruby/bundler/bundler-1.17.3-r1.ebuild b/dev-ruby/bundler/bundler-1.17.3-r1.ebuild
new file mode 100644
index 000000000000..024b1f86f52b
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.17.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="man"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git"
diff --git a/dev-ruby/bundler/bundler-2.1.2.ebuild b/dev-ruby/bundler/bundler-2.1.2.ebuild
new file mode 100644
index 000000000000..d7b0c12648b7
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+RUBY_FAKEGEM_EXTRAINSTALL="man"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !!<dev-ruby/bundler-1.17.3-r1:0"