summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-18 21:23:32 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-19 07:07:58 +0200
commit6594762ea9326bccd768378141456beddbbde4c5 (patch)
tree4c81403a021b5b58858ffa75198b0cdd1e7d127f /dev-ruby/bunny/bunny-2.5.1.ebuild
parentdev-ruby/bson: add 4.1.1 (diff)
downloadgentoo-6594762ea9326bccd768378141456beddbbde4c5.tar.gz
gentoo-6594762ea9326bccd768378141456beddbbde4c5.tar.bz2
gentoo-6594762ea9326bccd768378141456beddbbde4c5.zip
dev-ruby/bunny: add 2.5.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/bunny/bunny-2.5.1.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.5.1.ebuild b/dev-ruby/bunny/bunny-2.5.1.ebuild
new file mode 100644
index 000000000000..6a98443b2126
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.0.1:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}