summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-18 07:11:06 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-18 07:11:06 +0200
commitd4e7068f2d9d2bc9e66bb814445f2e534fa8294d (patch)
tree868fde9a0adf3fe76b0ce30dbb2b8db55616b10d /dev-ruby/capistrano/capistrano-3.4.1.ebuild
parentdev-ruby/rdtool: add ruby23 (diff)
downloadgentoo-d4e7068f2d9d2bc9e66bb814445f2e534fa8294d.tar.gz
gentoo-d4e7068f2d9d2bc9e66bb814445f2e534fa8294d.tar.bz2
gentoo-d4e7068f2d9d2bc9e66bb814445f2e534fa8294d.zip
dev-ruby/capistrano: add 3.4.1
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/capistrano/capistrano-3.4.1.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-3.4.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-3.4.1.ebuild b/dev-ruby/capistrano/capistrano-3.4.1.ebuild
new file mode 100644
index 000000000000..52be58d1e4b6
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/sshkit-1.3:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.12 )"
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}