summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-11 07:14:46 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-11 07:14:46 +0200
commitb398907d82f2ed7b128ec590c827ee7aff520e46 (patch)
tree742a94ba1bb2d73b888d3baf30f7ddffdfb327b0 /dev-ruby/capistrano/capistrano-3.9.1.ebuild
parentdev-ruby/omniauth: add 1.7.1 (diff)
downloadgentoo-b398907d82f2ed7b128ec590c827ee7aff520e46.tar.gz
gentoo-b398907d82f2ed7b128ec590c827ee7aff520e46.tar.bz2
gentoo-b398907d82f2ed7b128ec590c827ee7aff520e46.zip
dev-ruby/capistrano: add 3.9.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/capistrano/capistrano-3.9.1.ebuild')
-rw-r--r--dev-ruby/capistrano/capistrano-3.9.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/capistrano-3.9.1.ebuild b/dev-ruby/capistrano/capistrano-3.9.1.ebuild
new file mode 100644
index 000000000000..624e148e3b74
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.9.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+}
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}