summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-07 07:08:27 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-07 07:08:27 +0100
commita1091b6a6d8c46e3e9ead740c96155ac0c7a34a0 (patch)
treeb5d239034c530e34ae665b0f367ab5155c00aef7 /dev-ruby/childprocess/childprocess-0.5.9.ebuild
parentdev-ruby/childprocess: cleanup (diff)
downloadgentoo-a1091b6a6d8c46e3e9ead740c96155ac0c7a34a0.tar.gz
gentoo-a1091b6a6d8c46e3e9ead740c96155ac0c7a34a0.tar.bz2
gentoo-a1091b6a6d8c46e3e9ead740c96155ac0c7a34a0.zip
dev-ruby/childprocess: add 0.5.9
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.5.9.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.9.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.5.9.ebuild b/dev-ruby/childprocess/childprocess-0.5.9.ebuild
new file mode 100644
index 000000000000..1d6e50de8056
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:3 )"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}