summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-26 07:44:30 +0200
committerHans de Graaff <graaff@gentoo.org>2017-03-26 07:44:30 +0200
commit68a7e6d240f8599a1e93f39a20bc5a40f5bb0e31 (patch)
treebe63f2bed044aec2ed213c89c9b79228190adad2 /dev-ruby/childprocess/childprocess-0.6.3.ebuild
parentstablize openstack ocata - x86 and amd64 (diff)
downloadgentoo-68a7e6d240f8599a1e93f39a20bc5a40f5bb0e31.tar.gz
gentoo-68a7e6d240f8599a1e93f39a20bc5a40f5bb0e31.tar.bz2
gentoo-68a7e6d240f8599a1e93f39a20bc5a40f5bb0e31.zip
dev-ruby/childprocess: add 0.6.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/childprocess/childprocess-0.6.3.ebuild')
-rw-r--r--dev-ruby/childprocess/childprocess-0.6.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.6.3.ebuild b/dev-ruby/childprocess/childprocess-0.6.3.ebuild
new file mode 100644
index 000000000000..fa62aebdccf6
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.6.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:3 )"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}