summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/cmdparse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/cmdparse')
-rw-r--r--dev-ruby/cmdparse/Manifest2
-rw-r--r--dev-ruby/cmdparse/cmdparse-2.0.6-r1.ebuild27
-rw-r--r--dev-ruby/cmdparse/cmdparse-2.0.6.ebuild27
-rw-r--r--dev-ruby/cmdparse/cmdparse-3.0.1.ebuild23
-rw-r--r--dev-ruby/cmdparse/metadata.xml5
5 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/cmdparse/Manifest b/dev-ruby/cmdparse/Manifest
new file mode 100644
index 000000000000..38a935d28bd0
--- /dev/null
+++ b/dev-ruby/cmdparse/Manifest
@@ -0,0 +1,2 @@
+DIST cmdparse-2.0.6.gem 53760 SHA256 8a242a17e5147651ef59c2fdd11acd077b18299d24a21d1d8a0f18dfdc91337f SHA512 c4120b049e7d42d65be80649cdd097d17f8a732f090382759351617225f6235438f4338466e5e8c7b5c35675ca43d4930dc39b357263062ba7ae9c61c85f472e WHIRLPOOL 8944ea90f3d57bb2c9c308bc90a46184280b0e4ac563631c5ab931a8a5ea2ae3c42c6569cf775b4930bd1f9a1716d1f58e916a7b901a69733245464975ea9518
+DIST cmdparse-3.0.1.gem 53760 SHA256 4e38fc892e308ee834e19c6912c98c7059a053a7fe87d6908223422e43ed86c3 SHA512 8724ef46d543ee4677f9245b68b41c776cebfe7464dc63e3d785557883a10f4471810e90831873e3774c2597f55c32fcf48ac7efe6e494a63269ac713a3ce2ee WHIRLPOOL faf7d7e3c53f52ccacea85c108d7cc3c9cd54805057fb91f3dc0a83205cf264dfbdcee27e0e000be75d28b29c566dc8c7eb6928f3b0da7273daf3c88856d377a
diff --git a/dev-ruby/cmdparse/cmdparse-2.0.6-r1.ebuild b/dev-ruby/cmdparse/cmdparse-2.0.6-r1.ebuild
new file mode 100644
index 000000000000..7e61afa993d6
--- /dev/null
+++ b/dev-ruby/cmdparse/cmdparse-2.0.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc/output/rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+IUSE=""
+
+DESCRIPTION="Advanced command line parser supporting commands"
+HOMEPAGE="http://cmdparse.gettalong.org/"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+each_ruby_test() {
+ ${RUBY} -Ilib net.rb stat || die "test failed"
+}
diff --git a/dev-ruby/cmdparse/cmdparse-2.0.6.ebuild b/dev-ruby/cmdparse/cmdparse-2.0.6.ebuild
new file mode 100644
index 000000000000..e9fbb4792954
--- /dev/null
+++ b/dev-ruby/cmdparse/cmdparse-2.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="doc/output/rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+IUSE=""
+
+DESCRIPTION="Advanced command line parser supporting commands"
+HOMEPAGE="http://cmdparse.gettalong.org/"
+
+KEYWORDS="amd64 ppc64 x86"
+LICENSE="LGPL-3"
+SLOT="0"
+
+each_ruby_test() {
+ ${RUBY} -Ilib net.rb stat || die "test failed"
+}
diff --git a/dev-ruby/cmdparse/cmdparse-3.0.1.ebuild b/dev-ruby/cmdparse/cmdparse-3.0.1.ebuild
new file mode 100644
index 000000000000..4ebb46262dfc
--- /dev/null
+++ b/dev-ruby/cmdparse/cmdparse-3.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+IUSE=""
+
+DESCRIPTION="Advanced command line parser supporting commands"
+HOMEPAGE="http://cmdparse.gettalong.org/"
+
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="LGPL-3"
+SLOT="3"
diff --git a/dev-ruby/cmdparse/metadata.xml b/dev-ruby/cmdparse/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/cmdparse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>