summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-29 06:50:24 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-29 06:50:24 +0200
commitfd19ccbc12701a15aacb8e384706f48778a77309 (patch)
treeac343463696a544043ff7dd5ed766bd76523c9bb /dev-ruby/colorator/colorator-1.1.0.ebuild
parentnet-misc/teamviewer: Add png dependency for wine, resolves #580066 (diff)
downloadgentoo-fd19ccbc12701a15aacb8e384706f48778a77309.tar.gz
gentoo-fd19ccbc12701a15aacb8e384706f48778a77309.tar.bz2
gentoo-fd19ccbc12701a15aacb8e384706f48778a77309.zip
dev-ruby/colorator: add 1.1.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/colorator/colorator-1.1.0.ebuild')
-rw-r--r--dev-ruby/colorator/colorator-1.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/colorator/colorator-1.1.0.ebuild b/dev-ruby/colorator/colorator-1.1.0.ebuild
new file mode 100644
index 000000000000..dc00e6aff588
--- /dev/null
+++ b/dev-ruby/colorator/colorator-1.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Colorize your text in the terminal"
+HOMEPAGE="https://github.com/octopress/colorator"
+SRC_URI="https://github.com/octopress/colorator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile || die
+ sed -i -e "/luna/d" spec/spec/helper.rb || die
+}