summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-12-21 07:23:12 +0100
committerHans de Graaff <graaff@gentoo.org>2016-12-21 07:33:10 +0100
commitfd52aa36dca9eb13d1b36a42dcd1ab733f05d288 (patch)
tree1df647017178a26f6c789a500de4de1f9e55fd75 /dev-ruby/commander/commander-4.4.2.ebuild
parentmedia-radio/xlog: Version bump (diff)
downloadgentoo-fd52aa36dca9eb13d1b36a42dcd1ab733f05d288.tar.gz
gentoo-fd52aa36dca9eb13d1b36a42dcd1ab733f05d288.tar.bz2
gentoo-fd52aa36dca9eb13d1b36a42dcd1ab733f05d288.zip
dev-ruby/commander: add 4.4.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/commander/commander-4.4.2.ebuild')
-rw-r--r--dev-ruby/commander/commander-4.4.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/commander/commander-4.4.2.ebuild b/dev-ruby/commander/commander-4.4.2.ebuild
new file mode 100644
index 000000000000..9405544f456b
--- /dev/null
+++ b/dev-ruby/commander/commander-4.4.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://visionmedia.github.com/commander/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/highline-1.7.2 =dev-ruby/highline-1.7*"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}