summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-20 08:08:43 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-20 08:36:30 +0200
commit058b5d74e330e60d1b203a1d591f1b20830047e6 (patch)
tree8b23506c695ada388bd9f5d37d3df66b0382820e /dev-ruby/curb/curb-0.9.10.ebuild
parentdev-ruby/curb: cleanup (diff)
downloadgentoo-058b5d74e330e60d1b203a1d591f1b20830047e6.tar.gz
gentoo-058b5d74e330e60d1b203a1d591f1b20830047e6.tar.bz2
gentoo-058b5d74e330e60d1b203a1d591f1b20830047e6.zip
dev-ruby/curb: add 0.9.10
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/curb/curb-0.9.10.ebuild')
-rw-r--r--dev-ruby/curb/curb-0.9.10.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/curb/curb-0.9.10.ebuild b/dev-ruby/curb/curb-0.9.10.ebuild
new file mode 100644
index 000000000000..37839c5e5854
--- /dev/null
+++ b/dev-ruby/curb/curb-0.9.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="https://github.com/taf2/curb"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+ # fix tests when localhost is also ::1
+ sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+
+ # avoid tests making outside network connections
+ rm tests/bug_postfields_crash.rb || die
+ sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
+ -i tests/tc_curl_easy.rb || die
+ sed -e '/test_connection_keepalive/aomit "network connection needed"' \
+ -i tests/tc_curl_multi.rb || die
+
+ # avoid failing tests where failure condition seems weird, no
+ # upstream travis so not clear if the test is indeed broken.
+ sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+ cp -l ext/curb_core$(get_modname) lib || die
+}