summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-04-20 08:02:45 +0200
committerHans de Graaff <graaff@gentoo.org>2019-04-20 08:36:29 +0200
commit21d2c32a9b3e5416a87a84c559f86ca3060c46b2 (patch)
treecf6e8d5005139139cfee7fd1b4f4cfe39105a2f9 /dev-ruby/curb
parentapp-crypt/acmebot: new package, LetsEncrypt automation client (diff)
downloadgentoo-21d2c32a9b3e5416a87a84c559f86ca3060c46b2.tar.gz
gentoo-21d2c32a9b3e5416a87a84c559f86ca3060c46b2.tar.bz2
gentoo-21d2c32a9b3e5416a87a84c559f86ca3060c46b2.zip
dev-ruby/curb: cleanup
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/Manifest2
-rw-r--r--dev-ruby/curb/curb-0.9.7.ebuild45
-rw-r--r--dev-ruby/curb/curb-0.9.8.ebuild47
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
index 218a4bdd003c..23df56deb4c0 100644
--- a/dev-ruby/curb/Manifest
+++ b/dev-ruby/curb/Manifest
@@ -1,3 +1 @@
-DIST curb-0.9.7.gem 83968 BLAKE2B 591c4fde6fe809c813bb7586875e954dcc3b6190eb6955b5769a2dd1538d156074d0e025af6b1d42cbd820fb012b46eec4e9ca96fe61acc3697cf1f6c5018b43 SHA512 6068eaaad6b1dc2dbbf7d0588235ce2a681d786bf8ed6d072e501b7cbff600d8fbc9d675fac3949a565c8451641982cbd9ab29a50cf3707e8c4cdc35b539f42b
-DIST curb-0.9.8.gem 86528 BLAKE2B e96520e78e7126042ada0464a494af2d6547e581c638d3c1da85c98fd841ce86e81b3c13a2eaed26046048ab75614616a6b8f093fbb058ccae232768ea8ea4da SHA512 be57d572fd1703440e4f4127d55fdc6efdb5c30b50ca86ef5a66a5fd99667708771480cd3abf9be62aae7adb43fa41a03b57019ae7edbf03a9a7d7c2bbefeba9
DIST curb-0.9.9.gem 87040 BLAKE2B 107c6486887c0c168a06b7cdad4cc01e34a85c7cfb20e8991db4c695e9dfe3700655d95dbc798e4eb3269586b86d61037d0e39a88c4d687e0e776a0e9cc27f0e SHA512 3f91004e109f9cc7c2d58fb7a6bc387d037237442b05ee52bad2944738eb24bf8d909ad7c21db965ba1e6291d08f0f2335c54a5c1a1ee1d224c5790e81dc8037
diff --git a/dev-ruby/curb/curb-0.9.7.ebuild b/dev-ruby/curb/curb-0.9.7.ebuild
deleted file mode 100644
index 4f617df41cc2..000000000000
--- a/dev-ruby/curb/curb-0.9.7.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
- cp -l ext/curb_core$(get_modname) lib || die
-}
diff --git a/dev-ruby/curb/curb-0.9.8.ebuild b/dev-ruby/curb/curb-0.9.8.ebuild
deleted file mode 100644
index d7cd3e302948..000000000000
--- a/dev-ruby/curb/curb-0.9.8.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rake"
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Ruby-language bindings for libcurl"
-HOMEPAGE="https://github.com/taf2/curb"
-
-LICENSE="Ruby"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND+=" net-misc/curl[ssl]"
-RDEPEND+=" net-misc/curl[ssl]"
-
-all_ruby_prepare() {
- # fix tests when localhost is also ::1
- sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
-
- # avoid tests making outside network connections
- rm tests/bug_postfields_crash.rb || die
- sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
- -i tests/tc_curl_easy.rb || die
- sed -e '/test_connection_keepalive/aomit "network connection needed"' \
- -i tests/tc_curl_multi.rb || die
-
- # avoid failing tests where failure condition seems weird, no
- # upstream travis so not clear if the test is indeed broken.
- sed -i -e '/test_multi_easy_http/,/^ end/ s:^:#:' tests/tc_curl_multi.rb || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
- cp -l ext/curb_core$(get_modname) lib || die
-}