summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/curb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/curb')
-rw-r--r--dev-ruby/curb/Manifest2
-rw-r--r--dev-ruby/curb/curb-0.8.6.ebuild42
-rw-r--r--dev-ruby/curb/curb-0.8.8.ebuild42
-rw-r--r--dev-ruby/curb/metadata.xml8
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-ruby/curb/Manifest b/dev-ruby/curb/Manifest
new file mode 100644
index 000000000000..1d8b65bd793e
--- /dev/null
+++ b/dev-ruby/curb/Manifest
@@ -0,0 +1,2 @@
+DIST curb-0.8.6.gem 79872 SHA256 8c36f7f88f70fe12c23abd2238c6a83055a0bec41acd5c85695dea9ce91c54d0 SHA512 5dcba8907128bab39ce498ca6549ed8c4908754a2db1eeb1864915a6da59f52ef72aa173e03aa7ed1ff9be25da8c58d8af904d775cfdde5fd829634ea86389ec WHIRLPOOL 4a1ddace01046e19d480537efd29b0bd048ce55f9c32b4f68cc62de58b5295262b700fd0023760087b38597c90ff0b33ef9c3128f3a0320201ffffb9df82f5e9
+DIST curb-0.8.8.gem 80384 SHA256 ec3b5880d92c9a9140555fc5c86524025474a905e6548e1c37816247ad60903e SHA512 441025ae199266009bc3f8a2068245a4ee0b83f72babc35cc4fa744b0f3efe13ba26c5f795ff6f429bb7bfbd5ce31d51e5de6b65c3f10285d9a9f5909eff286f WHIRLPOOL e3e371d948fe1f008e34de944fc602267421f643eeec32a7408806dc6e7abc440e73ab63583273247330657ea7bebe7caa4957d95160ab66509110f2acf99ce5
diff --git a/dev-ruby/curb/curb-0.8.6.ebuild b/dev-ruby/curb/curb-0.8.6.ebuild
new file mode 100644
index 000000000000..06f462d34337
--- /dev/null
+++ b/dev-ruby/curb/curb-0.8.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="http://curb.rubyforge.org/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+ # fix tests when localhost is also ::1
+ sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+
+ # avoid tests making outside network connections
+ rm tests/bug_postfields_crash.rb || die
+ sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
+ -i tests/tc_curl_easy.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+ cp -l ext/curb_core$(get_modname) lib || die
+}
diff --git a/dev-ruby/curb/curb-0.8.8.ebuild b/dev-ruby/curb/curb-0.8.8.ebuild
new file mode 100644
index 000000000000..dbcc0da96db8
--- /dev/null
+++ b/dev-ruby/curb/curb-0.8.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby-language bindings for libcurl"
+HOMEPAGE="https://github.com/taf2/curb"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" net-misc/curl[ssl]"
+RDEPEND+=" net-misc/curl[ssl]"
+
+all_ruby_prepare() {
+ # fix tests when localhost is also ::1
+ sed -i -e 's|localhost:|127.0.0.1:|g' tests/*.rb || die
+
+ # avoid tests making outside network connections
+ rm tests/bug_postfields_crash.rb || die
+ sed -e '/test_easy_http_verbs_must_respond_to_str/,/^ end/ s:^:#:' \
+ -i tests/tc_curl_easy.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext CFLAGS="${CFLAGS} -fPIC" archflags="${LDFLAGS}" V=1
+ cp -l ext/curb_core$(get_modname) lib || die
+}
diff --git a/dev-ruby/curb/metadata.xml b/dev-ruby/curb/metadata.xml
new file mode 100644
index 000000000000..e98a2caac68a
--- /dev/null
+++ b/dev-ruby/curb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">taf2/curb</remote-id>
+ </upstream>
+</pkgmetadata>