summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/d3_rails
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/d3_rails')
-rw-r--r--dev-ruby/d3_rails/Manifest2
-rw-r--r--dev-ruby/d3_rails/d3_rails-3.5.5.ebuild23
-rw-r--r--dev-ruby/d3_rails/d3_rails-3.5.6.ebuild23
-rw-r--r--dev-ruby/d3_rails/metadata.xml8
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/d3_rails/Manifest b/dev-ruby/d3_rails/Manifest
new file mode 100644
index 000000000000..2bdc154593fb
--- /dev/null
+++ b/dev-ruby/d3_rails/Manifest
@@ -0,0 +1,2 @@
+DIST d3_rails-3.5.5.gem 133632 SHA256 8fedd753f9accdd3587753d4a89de901e5bd7d9e2ba1a5e91c52f564300eecfd SHA512 52a2aebe1422847ffc04e4209eb343bcc5651d659dbbb59bb1d17bd26b4b5cb6134641d23b91779a58f04829fa2baaafda6936d0d451cdd2b714588e7ca8473c WHIRLPOOL 57eef6744f6f0ef873213486819cc72093f4ea94a279ea86f54f635e3ab2ca9abec1bf35dcf2665f94ec71b6771560ae7c8eae987afb2f99fc584fb6cee5c36f
+DIST d3_rails-3.5.6.gem 134144 SHA256 556304fd34eace3008231e151df6ad8ed5870c59ecffc639ee1f810859225f39 SHA512 3a04a8886ec3cec21f9a880a69db539ba37247eaa4fe1aa053a0f408fbd0fbd78351d4218e2edabc7b5f8cd48ca28dfce5bc1bb64a1c62cc8623fd4ffc1e3d82 WHIRLPOOL a5c05049f848d17465a0835de69e21150e77b9a4da0b8d28144b02e57e3dfb90a1d4c3281e6832695ca4915152fc1caa61c657d3bd33700a77297948b4d348ec
diff --git a/dev-ruby/d3_rails/d3_rails-3.5.5.ebuild b/dev-ruby/d3_rails/d3_rails-3.5.5.ebuild
new file mode 100644
index 000000000000..a4dd92c84a9c
--- /dev/null
+++ b/dev-ruby/d3_rails/d3_rails-3.5.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails integration for the Javascript Data Visualization Framework, D3"
+HOMEPAGE="https://github.com/logical42/d3_rails"
+
+LICENSE="MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/railties-3.1"
diff --git a/dev-ruby/d3_rails/d3_rails-3.5.6.ebuild b/dev-ruby/d3_rails/d3_rails-3.5.6.ebuild
new file mode 100644
index 000000000000..1f5efec4aaa4
--- /dev/null
+++ b/dev-ruby/d3_rails/d3_rails-3.5.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby on Rails integration for the Javascript Data Visualization Framework, D3"
+HOMEPAGE="https://github.com/logical42/d3_rails"
+
+LICENSE="MIT BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/railties-3.1:*"
diff --git a/dev-ruby/d3_rails/metadata.xml b/dev-ruby/d3_rails/metadata.xml
new file mode 100644
index 000000000000..5f42f9a30b30
--- /dev/null
+++ b/dev-ruby/d3_rails/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">logical42/d3_rails</remote-id>
+ </upstream>
+</pkgmetadata>