summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-26 07:46:35 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-26 09:16:51 +0100
commit82f2555ccdfa07abc38a8442898b8eb33cc6a156 (patch)
treea77d81fbc7b837c96b63e7bc49202be47645ff6b /dev-ruby/daemon_controller
parentdev-ruby/color: cleanup (diff)
downloadgentoo-82f2555ccdfa07abc38a8442898b8eb33cc6a156.tar.gz
gentoo-82f2555ccdfa07abc38a8442898b8eb33cc6a156.tar.bz2
gentoo-82f2555ccdfa07abc38a8442898b8eb33cc6a156.zip
dev-ruby/daemon_controller: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..538b16a1b408
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to start and stop specific daemons programmatically in a robust manner"
+HOMEPAGE="https://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}