summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-08-03 08:14:19 +0200
committerHans de Graaff <graaff@gentoo.org>2016-08-03 08:14:19 +0200
commitda98134ef65ac3f6bbfa48636c5c6856f0bc0c68 (patch)
tree6a72332292b257ea9ea6b6103deb02688fb21d57 /dev-ruby/daemons/daemons-1.2.4.ebuild
parentprofiles: package.mask dev-perl/cdk-perl re bug #575036 (diff)
downloadgentoo-da98134ef65ac3f6bbfa48636c5c6856f0bc0c68.tar.gz
gentoo-da98134ef65ac3f6bbfa48636c5c6856f0bc0c68.tar.bz2
gentoo-da98134ef65ac3f6bbfa48636c5c6856f0bc0c68.zip
dev-ruby/daemons: add 1.2.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/daemons/daemons-1.2.4.ebuild')
-rw-r--r--dev-ruby/daemons/daemons-1.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/daemons/daemons-1.2.4.ebuild b/dev-ruby/daemons/daemons-1.2.4.ebuild
new file mode 100644
index 000000000000..01a2d81feabb
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}