summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-03-04 08:25:56 +0100
committerHans de Graaff <graaff@gentoo.org>2017-03-04 08:26:16 +0100
commit3c53f00514cb8cb5faf1e5e2af94a0ba882cadd9 (patch)
tree62919df7ffedf29d4fcc2251f7acd6334d4e56dc /dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
parentdev-ruby/oauth2: add 1.3.1 (diff)
downloadgentoo-3c53f00514cb8cb5faf1e5e2af94a0ba882cadd9.tar.gz
gentoo-3c53f00514cb8cb5faf1e5e2af94a0ba882cadd9.tar.bz2
gentoo-3c53f00514cb8cb5faf1e5e2af94a0ba882cadd9.zip
dev-ruby/ddplugin: initial import of 1.0.1
New dependency for www-apps/nanoc Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/ddplugin/ddplugin-1.0.1.ebuild')
-rw-r--r--dev-ruby/ddplugin/ddplugin-1.0.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild b/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
new file mode 100644
index 000000000000..698d1e3417af
--- /dev/null
+++ b/dev-ruby/ddplugin/ddplugin-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides plugin management for Ruby projects"
+HOMEPAGE="https://github.com/ddfreyne/ddplugin/"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}