summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/deprecated
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/deprecated')
-rw-r--r--dev-ruby/deprecated/Manifest1
-rw-r--r--dev-ruby/deprecated/deprecated-3.0.1-r1.ebuild26
-rw-r--r--dev-ruby/deprecated/deprecated-3.0.1-r2.ebuild26
-rw-r--r--dev-ruby/deprecated/metadata.xml9
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/deprecated/Manifest b/dev-ruby/deprecated/Manifest
new file mode 100644
index 000000000000..087bd37136a9
--- /dev/null
+++ b/dev-ruby/deprecated/Manifest
@@ -0,0 +1 @@
+DIST deprecated-3.0.1.gem 6144 SHA256 032cc3b7367275bebd2b46c0fa23f70447f65e7f34f0d68977b0c9243c07c2cf SHA512 c4280f8bd6914a6b073cbc443db5dd5232379abb7870d90cd0146c08312f82aa8fd8c042b48c2b9b26c4120dc8afb326070a1256c51355f1cfa898905ec59e51 WHIRLPOOL 383fc0a4736861cc56720c7307e40c7db09d626d6d61cad278c7793a969ab5061574b02d181f92c90d0f906977bd34ef0ea2f5929aab78a4f8e002c169e4a56b
diff --git a/dev-ruby/deprecated/deprecated-3.0.1-r1.ebuild b/dev-ruby/deprecated/deprecated-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..7b3cd195fdf7
--- /dev/null
+++ b/dev-ruby/deprecated/deprecated-3.0.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for handling deprecated code"
+HOMEPAGE="https://github.com/erikh/deprecated"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="amd64 ppc x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. test/test_deprecated.rb || die "test failed"
+}
diff --git a/dev-ruby/deprecated/deprecated-3.0.1-r2.ebuild b/dev-ruby/deprecated/deprecated-3.0.1-r2.ebuild
new file mode 100644
index 000000000000..4de6822ec3e4
--- /dev/null
+++ b/dev-ruby/deprecated/deprecated-3.0.1-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for handling deprecated code"
+HOMEPAGE="https://github.com/erikh/deprecated"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. test/test_deprecated.rb || die "test failed"
+}
diff --git a/dev-ruby/deprecated/metadata.xml b/dev-ruby/deprecated/metadata.xml
new file mode 100644
index 000000000000..dbbea9b0bee5
--- /dev/null
+++ b/dev-ruby/deprecated/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="rubyforge">deprecated</remote-id>
+ <remote-id type="github">erikh/deprecated</remote-id>
+ </upstream>
+</pkgmetadata>