summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-01-14 07:36:13 +0100
committerHans de Graaff <graaff@gentoo.org>2021-01-14 07:41:03 +0100
commitfb0d11538cc907c6353a042e0823417ce06f5ea5 (patch)
tree926ee49af0c6acf245f38014ed8a2a36c85989e8 /dev-ruby/docile/docile-1.3.5.ebuild
parentdev-ml/camlzip: ml maintains it (diff)
downloadgentoo-fb0d11538cc907c6353a042e0823417ce06f5ea5.tar.gz
gentoo-fb0d11538cc907c6353a042e0823417ce06f5ea5.tar.bz2
gentoo-fb0d11538cc907c6353a042e0823417ce06f5ea5.zip
dev-ruby/docile: add 1.3.5
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/docile/docile-1.3.5.ebuild')
-rw-r--r--dev-ruby/docile/docile-1.3.5.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/docile/docile-1.3.5.ebuild b/dev-ruby/docile/docile-1.3.5.ebuild
new file mode 100644
index 000000000000..3ea2744eb564
--- /dev/null
+++ b/dev-ruby/docile/docile-1.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+RUBY_FAKEGEM_GEMSPEC="docile.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Turns any Ruby object into a DSL"
+HOMEPAGE="https://ms-ati.github.io/docile/"
+SRC_URI="https://github.com/ms-ati/docile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/require \"github\/markup\"/d' Rakefile || die
+ sed -i -e '/^unless on/,/^end/ s:^:#:' spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}