summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-20 15:45:23 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-20 15:45:39 -0500
commitea66157f0139db0afc0f84456031e047d6c8c34f (patch)
tree77a64064c7ffe0cc7816ba3607d4babb660b8d55 /dev-ruby/facter
parentdev-libs/leatherman: 1.12.2 bump (diff)
downloadgentoo-ea66157f0139db0afc0f84456031e047d6c8c34f.tar.gz
gentoo-ea66157f0139db0afc0f84456031e047d6c8c34f.tar.bz2
gentoo-ea66157f0139db0afc0f84456031e047d6c8c34f.zip
dev-ruby/facter: 3.14.14 bump
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.14.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index 143edab7df9c..41baa7f3d54b 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,2 +1,3 @@
DIST facter-3.14.12.tar.gz 406896 BLAKE2B 5f25e9da754931c6318370877b0ab1158e47920c8d9776a24689b3b906a91beddfe6c32b584888f6c9131d8338eb3fcb3983f062767d16eb9da51572d0156c60 SHA512 599984d0cc86f65ab9c487963fe6e12513895079cf145d924910a53ceb702e3b59785ea073e695ec9acac36f8a7405ffcd1130eb338ce261a3af4213ef11f7d0
DIST facter-3.14.13.tar.gz 407204 BLAKE2B 12019c20284eb2a62fb65f2ab09246b98708b1aecb485700c2074865d02bb836f140802ad3b54f28c90fdd225b72e9216d21fb57dc0d82b8b3854607d5ba0eb7 SHA512 62910dc71aff0a0b0ef1ece054e0d1eea095c65ca6a34e17331aea943e217baa1a12bba1176143b652bb322195248a4aab1379eb69d6be419b73eb6ae3a8afac
+DIST facter-3.14.14.tar.gz 407276 BLAKE2B 5f911581773ef9a19ee42b5ed64114e2519ff88e024490d74bf9b1e777221d92d3ed502c8e6a0df573a5390fca323fcf0bcfdce6aeed25826c84efb3971307a5 SHA512 22e0ff0a9280be129f7587e24109f76f34660d99086378dd7e9ccc004c08a4fa5dd6f9ba50957c146ea40e26344ee87dbafd45b885f8f576192b6e572b084af7
diff --git a/dev-ruby/facter/facter-3.14.14.ebuild b/dev-ruby/facter/facter-3.14.14.ebuild
new file mode 100644
index 000000000000..b7819b83844f
--- /dev/null
+++ b/dev-ruby/facter/facter-3.14.14.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+# git-r3 goes after ruby-ng so that it overrides src_unpack properly
+inherit cmake-utils eutils ruby-ng
+
+DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
+ EGIT_BRANCH="master"
+else
+ [[ "${PV}" = *_rc* ]] || \
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+RESTRICT="!test? ( test )"
+
+ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
+
+RDEPEND="
+ >=dev-cpp/cpp-hocon-0.2.1:=
+ >=dev-libs/leatherman-1.0.0:=
+ dev-libs/openssl:0=
+ sys-apps/util-linux
+ app-emulation/virt-what
+ net-misc/curl
+ dev-libs/boost:=[nls]
+ >=dev-cpp/yaml-cpp-0.5.1
+ !<app-admin/puppet-4.0.0"
+DEPEND="${RDEPEND}"
+
+# restore ${S} and override all phases exported by ruby-ng.eclass
+S="${WORKDIR}/${P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
+ # be explicit about the version of rspec we test with
+ "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
+)
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+}
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ fi
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+each_ruby_configure() {
+ # hack for correct calculation of relative path from facter.rb to
+ # libfacter.so
+ my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
+}
+
+src_configure() {
+ ruby-ng_src_configure
+
+ local mycmakeargs=(
+ -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
+ -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ addpredict /proc/self/oom_score_adj
+ cmake-utils_src_compile
+}
+
+src_test() {
+ cmake-utils_src_test
+}
+
+each_ruby_install() {
+ doruby "${BUILD_DIR}"/lib/facter.rb
+}
+
+src_install() {
+ cmake-utils_src_install
+ ruby-ng_src_install
+}