summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/faraday
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/faraday')
-rw-r--r--dev-ruby/faraday/Manifest2
-rw-r--r--dev-ruby/faraday/faraday-0.9.0.ebuild59
-rw-r--r--dev-ruby/faraday/faraday-0.9.1.ebuild63
-rw-r--r--dev-ruby/faraday/metadata.xml8
4 files changed, 132 insertions, 0 deletions
diff --git a/dev-ruby/faraday/Manifest b/dev-ruby/faraday/Manifest
new file mode 100644
index 000000000000..196aa9b642b3
--- /dev/null
+++ b/dev-ruby/faraday/Manifest
@@ -0,0 +1,2 @@
+DIST faraday-0.9.0.tar.gz 53998 SHA256 0b3503ca485e25082ae20d67ec1f3594d802dc28e5f61e857b741520216f2927 SHA512 d69db4fced6edb7f161078d2fb3d60f11d8bbc14785e08a6aae262915a23cd3fd1f1b871a269491738e623b6b804626e812223678a5e3cc133baafc485c87dd4 WHIRLPOOL 3924f408edb4cc1e3d5df35c0b052f1f12d2f575b1671a4d5aaf4eb7b33e925e3fc5683b564e6d58ab556675022594abace05cf984b83652948c0e0e5c18a313
+DIST faraday-0.9.1.tar.gz 56944 SHA256 27c82ff6eb0b25da7077bd724edc545bc9438e25554fa259434f825ffeb20da5 SHA512 9686f8fd5adc4380dee0cefc3a18f3b8dbe9a7785bfea5e0332dbb6f4d3af4311698e87eb6ac7f070fd758d68fb5f9cf9beec81e86a05da7fe6a5ba6fded1a3b WHIRLPOOL 59f060c2bb1441de7fd55565050e8c47f826c3361b2ca37bac2f812d5f9ba4b49a639f37bb2bc73d49ed5c3e0c1633b7c82bd428fa0ebc01e5d68defbe0deb09
diff --git a/dev-ruby/faraday/faraday-0.9.0.ebuild b/dev-ruby/faraday/faraday-0.9.0.ebuild
new file mode 100644
index 000000000000..2da7e274ad98
--- /dev/null
+++ b/dev-ruby/faraday/faraday-0.9.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="HTTP/REST API client library with pluggable components"
+HOMEPAGE="http://github.com/lostisland/faraday"
+SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/multipart-post-1.2.0"
+ruby_add_bdepend "test? (
+ >=dev-ruby/test-unit-2.4
+ dev-ruby/sinatra
+ dev-ruby/net-http-persistent
+ dev-ruby/patron
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/helper.rb || die
+ sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
+
+ # Remove simplecov and coveralls support, not needed to run tests.
+ sed -i -e '/simplecov/,/^end/ s:^:#:' test/helper.rb || die
+
+ # Remove tests for adapters that are not packaged for Gentoo.
+ rm test/adapters/em_http_test.rb test/adapters/em_synchrony_test.rb test/adapters/excon_test.rb test/adapters/typhoeus_test.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the test scripts use the right ruby interpreter
+ sed -i -e 's:ruby:'${RUBY}':' script/* || die
+}
+
+each_ruby_test() {
+ each_fakegem_test
+
+ # Sleep some time to allow the sinatra test server to die
+ einfo "Waiting for test server to stop"
+ sleep 10
+}
diff --git a/dev-ruby/faraday/faraday-0.9.1.ebuild b/dev-ruby/faraday/faraday-0.9.1.ebuild
new file mode 100644
index 000000000000..24e0d17791fc
--- /dev/null
+++ b/dev-ruby/faraday/faraday-0.9.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="HTTP/REST API client library with pluggable components"
+HOMEPAGE="http://github.com/lostisland/faraday"
+SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" test? ( sys-process/lsof )"
+
+ruby_add_rdepend ">=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3"
+ruby_add_bdepend "test? (
+ >=dev-ruby/test-unit-2.4
+ dev-ruby/httpclient
+ dev-ruby/rack-test
+ dev-ruby/sinatra
+ dev-ruby/net-http-persistent
+ dev-ruby/patron
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/helper.rb || die
+ sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
+
+ # Remove simplecov and coveralls support, not needed to run tests.
+ sed -i -e '/simplecov/,/^ end/ s:^:#:' test/helper.rb || die
+
+ # Remove tests for adapters that are not packaged for Gentoo.
+ rm test/adapters/em_http_test.rb test/adapters/em_synchrony_test.rb test/adapters/excon_test.rb test/adapters/typhoeus_test.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the test scripts use the right ruby interpreter
+ sed -i -e 's:ruby:'${RUBY}':' script/* || die
+}
+
+each_ruby_test() {
+ each_fakegem_test
+
+ # Sleep some time to allow the sinatra test server to die
+ einfo "Waiting for test server to stop"
+ sleep 10
+}
diff --git a/dev-ruby/faraday/metadata.xml b/dev-ruby/faraday/metadata.xml
new file mode 100644
index 000000000000..ab8be285a1f8
--- /dev/null
+++ b/dev-ruby/faraday/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">lostisland/faraday</remote-id>
+ </upstream>
+</pkgmetadata>