summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fast_xs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fast_xs')
-rw-r--r--dev-ruby/fast_xs/Manifest1
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.8.0-r1.ebuild51
-rw-r--r--dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild50
-rw-r--r--dev-ruby/fast_xs/files/fast_xs-0.8.0+ruby-1.9.patch23
-rw-r--r--dev-ruby/fast_xs/metadata.xml8
5 files changed, 133 insertions, 0 deletions
diff --git a/dev-ruby/fast_xs/Manifest b/dev-ruby/fast_xs/Manifest
new file mode 100644
index 000000000000..9462e3ae5481
--- /dev/null
+++ b/dev-ruby/fast_xs/Manifest
@@ -0,0 +1 @@
+DIST fast_xs-0.8.0.gem 22016 SHA256 5ff2e1b088bdad3d4eae2a71b118b8aa9b39975702853c3bb307e35db1facdc7 SHA512 55fc2704fab020f03b1ce138d1631dd5ad73a8601dcd95989a59c7cccb490c70b4e1af59fb8b009bfa0899f2c23feb42cc3068e243cd539ba1cb01a9f7bc573b WHIRLPOOL e29bd2abf334e85809abb830968d9850439a5c50767aee0718ad5967c26b6ca9c9d7a9661a0bfc78a85e425634e69d6cac859eb59e8f57e29c481c8ca6969e3d
diff --git a/dev-ruby/fast_xs/fast_xs-0.8.0-r1.ebuild b/dev-ruby/fast_xs/fast_xs-0.8.0-r1.ebuild
new file mode 100644
index 000000000000..226fa79dd910
--- /dev/null
+++ b/dev-ruby/fast_xs/fast_xs-0.8.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="fast_xs text escaping library ruby bindings"
+HOMEPAGE="https://github.com/brianmario/fast_xs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.3.2 )"
+ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.3.2
+ dev-ruby/rack
+)"
+
+RUBY_PATCHES=( "${P}+ruby-1.9.patch" )
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
+ emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # the Rakefile tries to run all the tests in a single process, but
+ # this breaks the monkey-patchers, we're forced to run them one by
+ # one.
+ for tu in test/test_*.rb; do
+ ${RUBY} -Ilib $tu || die "test $tu failed"
+ done
+}
diff --git a/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild b/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild
new file mode 100644
index 000000000000..f77ded4b7937
--- /dev/null
+++ b/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="fast_xs text escaping library ruby bindings"
+HOMEPAGE="https://github.com/brianmario/fast_xs"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/hoe-2.3.2
+ dev-ruby/rack
+)"
+
+RUBY_PATCHES=( "${P}+ruby-1.9.patch" )
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
+ ${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
+ emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
+ cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ # the Rakefile tries to run all the tests in a single process, but
+ # this breaks the monkey-patchers, we're forced to run them one by
+ # one.
+ for tu in test/test_*.rb; do
+ ${RUBY} -Ilib $tu || die "test $tu failed"
+ done
+}
diff --git a/dev-ruby/fast_xs/files/fast_xs-0.8.0+ruby-1.9.patch b/dev-ruby/fast_xs/files/fast_xs-0.8.0+ruby-1.9.patch
new file mode 100644
index 000000000000..cdd72f2db3fb
--- /dev/null
+++ b/dev-ruby/fast_xs/files/fast_xs-0.8.0+ruby-1.9.patch
@@ -0,0 +1,23 @@
+Index: fast_xs-0.8.0/test/test_erb_util_module_overrides.rb
+===================================================================
+--- fast_xs-0.8.0.orig/test/test_erb_util_module_overrides.rb
++++ fast_xs-0.8.0/test/test_erb_util_module_overrides.rb
+@@ -35,11 +35,13 @@ class TestErbUtilModuleOverrides < Test:
+
+ def test_preserve_encoding
+ foo = "foo"
+- foo.force_encoding Encoding::US_ASCII
+- assert_equal Encoding::US_ASCII, url_encode(foo).encoding
+- assert_equal Encoding::US_ASCII, html_escape(foo).encoding
+- assert_equal Encoding::US_ASCII, u(foo).encoding
+- assert_equal Encoding::US_ASCII, h(foo).encoding
++ ascii_encoding = (RUBY_VERSION =~ /1\.9/) ? Encoding::ASCII_8BIT : Encoding::US_ASCII
++
++ foo.force_encoding ascii_encoding
++ assert_equal ascii_encoding, url_encode(foo).encoding
++ assert_equal ascii_encoding, html_escape(foo).encoding
++ assert_equal ascii_encoding, u(foo).encoding
++ assert_equal ascii_encoding, h(foo).encoding
+
+ foo.force_encoding Encoding::BINARY
+ assert_equal Encoding::BINARY, url_encode(foo).encoding
diff --git a/dev-ruby/fast_xs/metadata.xml b/dev-ruby/fast_xs/metadata.xml
new file mode 100644
index 000000000000..1c84f7c90983
--- /dev/null
+++ b/dev-ruby/fast_xs/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">brianmario/fast_xs</remote-id>
+ </upstream>
+</pkgmetadata>