summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/fcgi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/fcgi')
-rw-r--r--dev-ruby/fcgi/Manifest1
-rw-r--r--dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild34
-rw-r--r--dev-ruby/fcgi/fcgi-0.9.2.1.ebuild42
-rw-r--r--dev-ruby/fcgi/metadata.xml8
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-ruby/fcgi/Manifest b/dev-ruby/fcgi/Manifest
new file mode 100644
index 000000000000..7e88ecd606b9
--- /dev/null
+++ b/dev-ruby/fcgi/Manifest
@@ -0,0 +1 @@
+DIST fcgi-0.9.2.1.gem 15872 SHA256 f5e18b6769dfea1760e3da1dae1df7ade140cd5c1394e9318e36d9834f13ca1e SHA512 1ffdd429ce4f2bbac771b7ac2368a5194015a7327b8b43b803914257edc174235573df6bb41a53fb71db0bf179fc24ce2392b244b5b55563d67e045c47da8579 WHIRLPOOL 722307e332bc6e584a144a5a5ca667f960edcadcf730aef4a91bde6caaf4d65d1f64028c067d82418dd7e1276f053196fa8a15c0a7b2f7616e9ca796a9239757
diff --git a/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild b/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
new file mode 100644
index 000000000000..358a25086f45
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.9.2.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.signals"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://github.com/alphallc/ruby-fcgi-ng"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_configure() {
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
+}
diff --git a/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild b/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild
new file mode 100644
index 000000000000..ffeeb335ad6e
--- /dev/null
+++ b/dev-ruby/fcgi/fcgi-0.9.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc README.signals"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="FastCGI library for Ruby"
+HOMEPAGE="http://github.com/alphallc/ruby-fcgi-ng"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+LICENSE="Ruby"
+
+DEPEND+=" dev-libs/fcgi"
+RDEPEND+=" dev-libs/fcgi"
+
+IUSE=""
+SLOT="0"
+
+each_ruby_configure() {
+ case ${RUBY} in
+ *ruby19|*ruby20)
+ ${RUBY} -C ext/fcgi extconf.rb || die "extconf failed"
+ ;;
+ esac
+}
+
+each_ruby_compile() {
+ case ${RUBY} in
+ *ruby19|*ruby20)
+ emake V=1 -C ext/fcgi
+ cp ext/fcgi/fcgi$(get_modname) lib || die
+ ;;
+ esac
+}
diff --git a/dev-ruby/fcgi/metadata.xml b/dev-ruby/fcgi/metadata.xml
new file mode 100644
index 000000000000..5c7bcbb69f47
--- /dev/null
+++ b/dev-ruby/fcgi/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">alphallc/ruby-fcgi-ng</remote-id>
+ </upstream>
+</pkgmetadata>