summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-01-15 07:41:54 +0100
committerHans de Graaff <graaff@gentoo.org>2022-01-15 07:41:54 +0100
commit0c30221201d8600218c39490af8f99f94db3242b (patch)
tree23f63b24b54f43eec57aa91f5051182111c83750 /dev-ruby/flexmock
parentdev-ruby/childlabor: cleanup (diff)
downloadgentoo-0c30221201d8600218c39490af8f99f94db3242b.tar.gz
gentoo-0c30221201d8600218c39490af8f99f94db3242b.tar.bz2
gentoo-0c30221201d8600218c39490af8f99f94db3242b.zip
dev-ruby/flexmock: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/flexmock')
-rw-r--r--dev-ruby/flexmock/flexmock-2.3.6.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-ruby/flexmock/flexmock-2.3.6.ebuild b/dev-ruby/flexmock/flexmock-2.3.6.ebuild
deleted file mode 100644
index e5a0cab2284e..000000000000
--- a/dev-ruby/flexmock/flexmock-2.3.6.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_DOCDIR="html"
-RUBY_FAKEGEM_EXTRADOC="CHANGES README.md doc/*.rdoc doc/releases/*"
-
-RUBY_FAKEGEM_RECIPE_TEST="none"
-RUBY_FAKEGEM_RECIPE_DOC="none"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Simple mock object library for Ruby unit testing"
-HOMEPAGE="https://github.com/doudou/flexmock"
-SRC_URI="https://github.com/doudou/flexmock/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="flexmock"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- test? (
- dev-ruby/minitest:5
- dev-ruby/rspec:3
- )"
-
-each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec test/rspec_integration
- ${RUBY} -Ilib:.:test -e 'Dir["test/*_test.rb"].each{|f| require f}' || die
-}
-
-all_ruby_prepare() {
- sed -i -e '1igem "minitest", "~>5.0"' test/test_helper.rb || die
-}