summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-02-19 22:59:15 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2020-02-19 23:03:14 -0800
commit034d9bc2b20401b6ee70ca4f2c91dc0e7d685eb1 (patch)
tree328f06738f820ad149f9b761a3f3b7161410dbf9 /dev-ruby/gist/gist-5.1.0.ebuild
parentdev-ruby/shoulda-matchers: add 4.3.0 (diff)
downloadgentoo-034d9bc2b20401b6ee70ca4f2c91dc0e7d685eb1.tar.gz
gentoo-034d9bc2b20401b6ee70ca4f2c91dc0e7d685eb1.tar.bz2
gentoo-034d9bc2b20401b6ee70ca4f2c91dc0e7d685eb1.zip
dev-ruby/gist: bump for service requirements change
GitHub has changed the authentication method slightly, discontining support for the old access_token query parameter. All consumers should move to headers [1] instead. Support for the old method ends 2020/07/01. [1] https://developer.github.com/changes/2019-11-05-deprecated-passwords-and-authorizations-api/#authenticating-using-query-parameters Fixes: https://github.com/defunkt/gist/pull/308 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'dev-ruby/gist/gist-5.1.0.ebuild')
-rw-r--r--dev-ruby/gist/gist-5.1.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/gist/gist-5.1.0.ebuild b/dev-ruby/gist/gist-5.1.0.ebuild
new file mode 100644
index 000000000000..f5655faac28f
--- /dev/null
+++ b/dev-ruby/gist/gist-5.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Potentially the best command line gister."
+HOMEPAGE="https://github.com/defunkt/gist"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-python/txgithub also installs a 'gist' binary.
+RDEPEND="!dev-python/txgithub"