summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-13 07:35:05 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-13 08:08:05 +0100
commiteb9dee6ef529c39d7cca9ee1f29472814177befd (patch)
treede11a8eaab6491ef0213f564e2be4af0839c5559 /dev-ruby/gist/gist-6.0.0.ebuild
parentdev-util/geany-plugins: stabilize 1.37-r101 on ppc (diff)
downloadgentoo-eb9dee6ef529c39d7cca9ee1f29472814177befd.tar.gz
gentoo-eb9dee6ef529c39d7cca9ee1f29472814177befd.tar.bz2
gentoo-eb9dee6ef529c39d7cca9ee1f29472814177befd.zip
dev-ruby/gist: add 6.0.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/gist/gist-6.0.0.ebuild')
-rw-r--r--dev-ruby/gist/gist-6.0.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/gist/gist-6.0.0.ebuild b/dev-ruby/gist/gist-6.0.0.ebuild
new file mode 100644
index 000000000000..b929beb9c1c8
--- /dev/null
+++ b/dev-ruby/gist/gist-6.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Potentially the best command line gister."
+HOMEPAGE="https://github.com/defunkt/gist"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+# dev-python/txgithub also installs a 'gist' binary.
+RDEPEND="!dev-python/txgithub"
+
+ruby_add_bdepend "test? ( dev-ruby/webmock )"