summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-17 06:51:33 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-17 06:51:33 +0200
commitaedad04537548fe6b4d84d36fcd373d5203102cc (patch)
tree9a6e1663bde132576a6a1fd3999b45883f2ba3dc /dev-ruby/git/git-1.4.0.ebuild
parentdev-ruby/bcrypt-ruby: add 3.1.12 (diff)
downloadgentoo-aedad04537548fe6b4d84d36fcd373d5203102cc.tar.gz
gentoo-aedad04537548fe6b4d84d36fcd373d5203102cc.tar.bz2
gentoo-aedad04537548fe6b4d84d36fcd373d5203102cc.zip
dev-ruby/git: add 1.4.0
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/git/git-1.4.0.ebuild')
-rw-r--r--dev-ruby/git/git-1.4.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/git/git-1.4.0.ebuild b/dev-ruby/git/git-1.4.0.ebuild
new file mode 100644
index 000000000000..157b12a8f86b
--- /dev/null
+++ b/dev-ruby/git/git-1.4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_GEMSPEC="git.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for using Git in Ruby"
+HOMEPAGE="https://github.com/schacon/ruby-git"
+SRC_URI="https://github.com/schacon/ruby-git/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-git-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND+="test? ( >=dev-vcs/git-1.6.0.0 app-arch/tar )"
+RDEPEND+=">=dev-vcs/git-1.6.0.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ # Don't use hardcoded /tmp directory.
+ sed -i -e "s:/tmp:${TMPDIR}:" tests/units/test_archive.rb tests/test_helper.rb || die
+}