summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-27 07:16:29 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-27 07:19:48 +0200
commit5df8167b082abb822f27c18e0acfbd70853f2c93 (patch)
tree94d160769731c39621fd31947915639f74e34a8f /dev-ruby/globalid/globalid-0.3.7.ebuild
parentwww-apache/passenger: add 5.0.30 (diff)
downloadgentoo-5df8167b082abb822f27c18e0acfbd70853f2c93.tar.gz
gentoo-5df8167b082abb822f27c18e0acfbd70853f2c93.tar.bz2
gentoo-5df8167b082abb822f27c18e0acfbd70853f2c93.zip
dev-ruby/globalid: add 0.3.7
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/globalid/globalid-0.3.7.ebuild')
-rw-r--r--dev-ruby/globalid/globalid-0.3.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-0.3.7.ebuild b/dev-ruby/globalid/globalid-0.3.7.ebuild
new file mode 100644
index 000000000000..9347934ade17
--- /dev/null
+++ b/dev-ruby/globalid/globalid-0.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-4.1.0 >=dev-ruby/railties-4.1.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-4.1.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+}