summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-04-17 07:06:16 +0200
committerHans de Graaff <graaff@gentoo.org>2017-04-17 07:06:16 +0200
commit360cb26f734226fd1ef1d7396a1cfa2a3d437591 (patch)
tree832d6598a9b2a14122401cb3c4ceca76ad0bde22 /dev-ruby/globalid/globalid-0.4.0.ebuild
parentnet-dns/libidn2: Fix prefix by Laine Gholson (bug #615808). (diff)
downloadgentoo-360cb26f734226fd1ef1d7396a1cfa2a3d437591.tar.gz
gentoo-360cb26f734226fd1ef1d7396a1cfa2a3d437591.tar.bz2
gentoo-360cb26f734226fd1ef1d7396a1cfa2a3d437591.zip
dev-ruby/globalid: add 0.4.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/globalid/globalid-0.4.0.ebuild')
-rw-r--r--dev-ruby/globalid/globalid-0.4.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/globalid/globalid-0.4.0.ebuild b/dev-ruby/globalid/globalid-0.4.0.ebuild
new file mode 100644
index 000000000000..0112e2f176c4
--- /dev/null
+++ b/dev-ruby/globalid/globalid-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Reference models by URI"
+HOMEPAGE="https://github.com/rails/globalid"
+SRC_URI="https://github.com/rails/globalid/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/bundler >=dev-ruby/activemodel-4.2.0 >=dev-ruby/railties-4.2.0 )"
+ruby_add_rdepend ">=dev-ruby/activesupport-4.2.0:*"
+
+all_ruby_prepare() {
+ rm -f Gemfile.lock || die
+}