summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-15 07:24:03 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-15 07:24:03 +0200
commita8fcdb36cb16f34d4dc151a5f15f8fe6c3186e7c (patch)
treea130e25c966017f2fb9b98fb4badbc0d99165c75 /dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild
parentdev-ruby/google-protobuf: cleanup (diff)
downloadgentoo-a8fcdb36cb16f34d4dc151a5f15f8fe6c3186e7c.tar.gz
gentoo-a8fcdb36cb16f34d4dc151a5f15f8fe6c3186e7c.tar.bz2
gentoo-a8fcdb36cb16f34d4dc151a5f15f8fe6c3186e7c.zip
dev-ruby/google-protobuf: add 3.12.4
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild')
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild
new file mode 100644
index 000000000000..3787f73873a7
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.12.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.12.0 )"
+
+all_ruby_prepare() {
+ sed -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^ end/ s:^:#:' \
+ -e 's:../src/protoc:protoc:' \
+ -e 's/:compile,//' \
+ -i Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}