summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/gruff
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/gruff')
-rw-r--r--dev-ruby/gruff/Manifest2
-rw-r--r--dev-ruby/gruff/files/gruff-0.3.6-spider.patch13
-rw-r--r--dev-ruby/gruff/gruff-0.5.1-r1.ebuild46
-rw-r--r--dev-ruby/gruff/gruff-0.5.1.ebuild46
-rw-r--r--dev-ruby/gruff/gruff-0.6.0.ebuild45
-rw-r--r--dev-ruby/gruff/metadata.xml9
6 files changed, 161 insertions, 0 deletions
diff --git a/dev-ruby/gruff/Manifest b/dev-ruby/gruff/Manifest
new file mode 100644
index 000000000000..79c04cdf2e86
--- /dev/null
+++ b/dev-ruby/gruff/Manifest
@@ -0,0 +1,2 @@
+DIST gruff-0.5.1.gem 315904 SHA256 34a3cea74d8f87182dcd8ae0a7981e58a49870cd8bb9aedb4b11e5cf56bccb2d SHA512 30453b6af286548be4727c124662df1b05ef93acb25a443cdb7b02c7076dddcbd71769fa249402456e5f54e27d40e4bb6cd8ba012c1746b3190c7a27c505b8f3 WHIRLPOOL bdd8f72c78780fd2b070edfe21a5f7e0d84c86baf6026bd53e40cf934d279c2cc36f139042fbe1e32fe4dc9e0016771b781ffcff304b1043258f7f9cfb7dc441
+DIST gruff-0.6.0.gem 316416 SHA256 d44116afdc914a98143fd455004f4aeb725942e8a61650c93e1fde7d307de4b2 SHA512 4771637157d11c85d437d41d63d018915d1214fd09dc7078b883c98f640821aec3ddc64fcd4516ca4bfd06c9523ee5a4b60dc6233903e03d7336ad10989613cb WHIRLPOOL dc55cfe4ca44c85ae753395272492bc8c0091145b48421e7e3da67347525deb07cfb5470c95e7c00bd5369634566794c645059f9dad2e12744578140a92b5207
diff --git a/dev-ruby/gruff/files/gruff-0.3.6-spider.patch b/dev-ruby/gruff/files/gruff-0.3.6-spider.patch
new file mode 100644
index 000000000000..0e7a8bbcfab8
--- /dev/null
+++ b/dev-ruby/gruff/files/gruff-0.3.6-spider.patch
@@ -0,0 +1,13 @@
+--- lib/gruff/spider.rb.orig 2007-03-08 10:22:36.000000000 +0100
++++ lib/gruff/spider.rb 2007-03-08 10:38:50.000000000 +0100
+@@ -34,8 +34,8 @@
+ return unless @has_data
+
+ # Setup basic positioning
+- diameter = @graph_height
+- radius = @graph_height / 2.0
++ diameter = @graph_height - 50
++ radius = diameter / 2.0
+ top_x = @graph_left + (@graph_width - diameter) / 2.0
+ center_x = @graph_left + (@graph_width / 2.0)
+ center_y = @graph_top + (@graph_height / 2.0) - 25 # Move graph up a bit
diff --git a/dev-ruby/gruff/gruff-0.5.1-r1.ebuild b/dev-ruby/gruff/gruff-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..8e5a9a1d7d3a
--- /dev/null
+++ b/dev-ruby/gruff/gruff-0.5.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
+
+inherit ruby-fakegem
+
+ruby_add_rdepend '>=dev-ruby/rmagick-2'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ )"
+
+DESCRIPTION="RMagick Implementation for JRuby"
+HOMEPAGE="http://rubyforge.org/projects/gruff/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.3.6-spider.patch
+)
+
+# imagemagick is an indirect dependency through rmagick. However, for
+# gruff to work properly imagemagick needs to be compiled with truetype
+# support and this cannot be expressed in the rmagick dependency. Tests
+# also require imagemagick to have jpeg and png support.
+DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,png,truetype] )"
+RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/gruff/gruff-0.5.1.ebuild b/dev-ruby/gruff/gruff-0.5.1.ebuild
new file mode 100644
index 000000000000..c94fcd28467b
--- /dev/null
+++ b/dev-ruby/gruff/gruff-0.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
+
+inherit ruby-fakegem
+
+ruby_add_rdepend '>=dev-ruby/rmagick-2'
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ )"
+
+DESCRIPTION="RMagick Implementation for JRuby"
+HOMEPAGE="http://rubyforge.org/projects/gruff/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-macos"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.3.6-spider.patch
+)
+
+# imagemagick is an indirect dependency through rmagick. However, for
+# gruff to work properly imagemagick needs to be compiled with
+# truetype support and this cannot be expressed in the rmagick
+# dependency. Test also require imagemagick to have jpeg support.
+DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,truetype] )"
+RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/gruff/gruff-0.6.0.ebuild b/dev-ruby/gruff/gruff-0.6.0.ebuild
new file mode 100644
index 000000000000..9c78a4a3a41c
--- /dev/null
+++ b/dev-ruby/gruff/gruff-0.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.md RELEASE.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets rails_generators"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful graphs for one or multiple datasets"
+HOMEPAGE="https://github.com/topfunky/gruff"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+RUBY_PATCHES=(
+ ${PN}-0.3.6-spider.patch
+)
+
+# imagemagick is an indirect dependency through rmagick. However, for
+# gruff to work properly imagemagick needs to be compiled with truetype
+# support and this cannot be expressed in the rmagick dependency. Tests
+# also require imagemagick to have jpeg and png support.
+DEPEND="${DEPEND} test? ( media-gfx/imagemagick[jpeg,png,truetype] )"
+RDEPEND="${RDEPEND} media-gfx/imagemagick[truetype]"
+
+ruby_add_rdepend ">=dev-ruby/rmagick-2.13.4"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/test-unit
+ )"
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/test_*.rb
+}
diff --git a/dev-ruby/gruff/metadata.xml b/dev-ruby/gruff/metadata.xml
new file mode 100644
index 000000000000..9fce92c99647
--- /dev/null
+++ b/dev-ruby/gruff/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="rubyforge">gruff</remote-id>
+ <remote-id type="github">topfunky/gruff</remote-id>
+ </upstream>
+</pkgmetadata>