summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-03-27 14:06:41 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-03-27 14:06:41 +0200
commite71b8160a8edca926918e729ddb9af6034a5cb71 (patch)
tree71437636ff1a22b44a4b6756f3bec00e2c6be576 /dev-ruby/haml-rails/haml-rails-0.9.0.ebuild
parentkde-misc/plasma-applet-redshift-control: Remove old (diff)
downloadgentoo-e71b8160a8edca926918e729ddb9af6034a5cb71.tar.gz
gentoo-e71b8160a8edca926918e729ddb9af6034a5cb71.tar.bz2
gentoo-e71b8160a8edca926918e729ddb9af6034a5cb71.zip
dev-ruby/haml-rails: Initial version
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/haml-rails/haml-rails-0.9.0.ebuild')
-rw-r--r--dev-ruby/haml-rails/haml-rails-0.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/haml-rails/haml-rails-0.9.0.ebuild b/dev-ruby/haml-rails/haml-rails-0.9.0.ebuild
new file mode 100644
index 000000000000..9cb34c2f17b1
--- /dev/null
+++ b/dev-ruby/haml-rails/haml-rails-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides Haml generators for Rails 4"
+HOMEPAGE="https://github.com/indirect/haml-rails"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/actionpack-4.0.1
+ >=dev-ruby/activesupport-4.0.1
+ >=dev-ruby/railties-4.0.1
+ >=dev-ruby/haml-4.0.6
+ >=dev-ruby/html2haml-1.0.1"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rails-4.0.1 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+}