summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-10-19 07:18:39 +0200
committerHans de Graaff <graaff@gentoo.org>2015-10-20 07:05:34 +0200
commitff1b573c62f8696f363897a3ac13000f8ff63f74 (patch)
tree4c6a452bed9d558b05ed0001236cc482d48dc18d /dev-ruby/highline/highline-1.7.8.ebuild
parentdev-ruby/highline: cleanup (diff)
downloadgentoo-ff1b573c62f8696f363897a3ac13000f8ff63f74.tar.gz
gentoo-ff1b573c62f8696f363897a3ac13000f8ff63f74.tar.bz2
gentoo-ff1b573c62f8696f363897a3ac13000f8ff63f74.zip
dev-ruby/highline: add 1.7.8
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/highline/highline-1.7.8.ebuild')
-rw-r--r--dev-ruby/highline/highline-1.7.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/highline/highline-1.7.8.ebuild b/dev-ruby/highline/highline-1.7.8.ebuild
new file mode 100644
index 000000000000..07bc7fc67114
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}