summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hipchat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hipchat')
-rw-r--r--dev-ruby/hipchat/Manifest3
-rw-r--r--dev-ruby/hipchat/hipchat-1.4.0.ebuild37
-rw-r--r--dev-ruby/hipchat/hipchat-1.5.1.ebuild37
-rw-r--r--dev-ruby/hipchat/hipchat-1.5.2.ebuild37
-rw-r--r--dev-ruby/hipchat/metadata.xml8
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-ruby/hipchat/Manifest b/dev-ruby/hipchat/Manifest
new file mode 100644
index 000000000000..d8157e781ff5
--- /dev/null
+++ b/dev-ruby/hipchat/Manifest
@@ -0,0 +1,3 @@
+DIST hipchat-1.4.0.tar.gz 14567 SHA256 d0686c3bd87516c02c0bfcb0512f84b6151cc88150c6b15d81719bf3d07d43fa SHA512 a599c6cf0c65f1421f83e99a73ab22dfaf4da229c6ee9871fed6698e5543bca581b3168d6577d6e2103506038567a6d9b279f338a3185547f1920460b5185d6e WHIRLPOOL d1990cc6eb74c2a408e17781cbb2127f8c9dea19df022e3452f87563386182030e410370a83feb970e24238d9712388ac16e747f6a776e0ae6c8e8815486b02e
+DIST hipchat-1.5.1.tar.gz 16227 SHA256 5e9ba9ac8fb339fff78c10d4ad19c1570530aac38bfed936088958426f72f97a SHA512 ae385c3fce6f09a9c9a23e44651580ed68e53a354faa588d648a3c8ea2797b86313e91ef7dd25583c2ccaf7f4033ef9a4595ea9a6495f5f234415207fa7260d3 WHIRLPOOL 62d86e371ae75742be97df60e8be13bff9678367d2544a044174796df37e18c4412daff2f235959f541ce48f09845d81ccb38e7645ee50ee71659578a9a89820
+DIST hipchat-1.5.2.tar.gz 16549 SHA256 624660f5be9d16ae847c817e4dcfb4745c64ef76987533f5c1c33fd03e20f035 SHA512 98f8287d922eb141ee7eca37bd658b81b7b2b0800c82d9576aef0869b928f7b5e00cecc65ca2041b69eedadb002928ed89f0cf500c9dc5d5cad05430e9ec9932 WHIRLPOOL 7693a46d7f165b95ff8f3270d11094e13b0da6782bf010cb284ae871659cd7902217fd9d1fe6117be4d923dc975d1aa26f9411b48391cc53152a36d472a52eea
diff --git a/dev-ruby/hipchat/hipchat-1.4.0.ebuild b/dev-ruby/hipchat/hipchat-1.4.0.ebuild
new file mode 100644
index 000000000000..120b3f54a1a8
--- /dev/null
+++ b/dev-ruby/hipchat/hipchat-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library to interact with HipChat"
+HOMEPAGE="https://github.com/hipchat/hipchat-rb"
+SRC_URI="https://github.com/hipchat/hipchat-rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="hipchat-rb-${PV}"
+
+ruby_add_rdepend "dev-ruby/httparty"
+ruby_add_bdepend "test? (
+ dev-ruby/rr
+ dev-ruby/rake
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/git ls-files/d' ${PN}.gemspec || die "sed failed"
+
+ sed -i -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hipchat/hipchat-1.5.1.ebuild b/dev-ruby/hipchat/hipchat-1.5.1.ebuild
new file mode 100644
index 000000000000..d6eff1055c49
--- /dev/null
+++ b/dev-ruby/hipchat/hipchat-1.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library to interact with HipChat"
+HOMEPAGE="https://github.com/hipchat/hipchat-rb"
+SRC_URI="https://github.com/hipchat/hipchat-rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="hipchat-rb-${PV}"
+
+ruby_add_rdepend "dev-ruby/httparty dev-ruby/mimemagic"
+ruby_add_bdepend "test? (
+ dev-ruby/rr
+ dev-ruby/rake
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/git ls-files/d' ${PN}.gemspec || die "sed failed"
+
+ sed -i -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hipchat/hipchat-1.5.2.ebuild b/dev-ruby/hipchat/hipchat-1.5.2.ebuild
new file mode 100644
index 000000000000..d9e78f35a3c8
--- /dev/null
+++ b/dev-ruby/hipchat/hipchat-1.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library to interact with HipChat"
+HOMEPAGE="https://github.com/hipchat/hipchat-rb"
+SRC_URI="https://github.com/hipchat/hipchat-rb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="hipchat-rb-${PV}"
+
+ruby_add_rdepend "dev-ruby/httparty dev-ruby/mimemagic"
+ruby_add_bdepend "test? (
+ dev-ruby/rr
+ dev-ruby/rake
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/d' Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/git ls-files/d' ${PN}.gemspec || die "sed failed"
+
+ sed -i -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hipchat/metadata.xml b/dev-ruby/hipchat/metadata.xml
new file mode 100644
index 000000000000..eb4036af7861
--- /dev/null
+++ b/dev-ruby/hipchat/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">hipchat/hipchat-rb</remote-id>
+ </upstream>
+</pkgmetadata>