summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hitimes
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hitimes')
-rw-r--r--dev-ruby/hitimes/Manifest1
-rw-r--r--dev-ruby/hitimes/hitimes-1.2.2.ebuild36
-rw-r--r--dev-ruby/hitimes/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/hitimes/Manifest b/dev-ruby/hitimes/Manifest
new file mode 100644
index 000000000000..d0895cdc451b
--- /dev/null
+++ b/dev-ruby/hitimes/Manifest
@@ -0,0 +1 @@
+DIST hitimes-1.2.2.gem 32256 SHA256 c44a808cafedd9a3571a1990668ce1f5f60b7e1ab6bd8b5feaa60edaf17bc39f SHA512 c12ae48444c22b90f7ca264c8a8a80917b605de03832a9ced9a03c442461dfa3f33dd67129ff512ee196af97895491a7f378fff5a26bfa09a8c50cf6feadb9ac WHIRLPOOL 8b7d66ab263fd58b000e29948209795361451fc5721d083fe86291233726616df9ddefa34c82e9b16bc7991859dbfc8b65ebc6c2e12f7e48a2be7f7fdc282f79
diff --git a/dev-ruby/hitimes/hitimes-1.2.2.ebuild b/dev-ruby/hitimes/hitimes-1.2.2.ebuild
new file mode 100644
index 000000000000..bfce40db091a
--- /dev/null
+++ b/dev-ruby/hitimes/hitimes-1.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md HISTORY.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A fast, high resolution timer library"
+HOMEPAGE="https://github.com/copiousfreetime/hitimes"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/RUBY_VERSION >= '1.9.2'/,+4d" spec/spec_helper.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/hitimes/c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/hitimes/c V=1
+ cp ext/hitimes/c/hitimes$(get_modname) lib/hitimes || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:spec:. -e 'Dir["spec/*_spec.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/hitimes/metadata.xml b/dev-ruby/hitimes/metadata.xml
new file mode 100644
index 000000000000..cfa70c53b1d9
--- /dev/null
+++ b/dev-ruby/hitimes/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">copiousfreetime/hitimes</remote-id>
+ </upstream>
+</pkgmetadata>