summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hpricot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hpricot')
-rw-r--r--dev-ruby/hpricot/Manifest1
-rw-r--r--dev-ruby/hpricot/files/hpricot-0.8.6-fast_xs.patch24
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild69
-rw-r--r--dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild57
-rw-r--r--dev-ruby/hpricot/metadata.xml5
5 files changed, 156 insertions, 0 deletions
diff --git a/dev-ruby/hpricot/Manifest b/dev-ruby/hpricot/Manifest
new file mode 100644
index 000000000000..ef1c0f3d2e31
--- /dev/null
+++ b/dev-ruby/hpricot/Manifest
@@ -0,0 +1 @@
+DIST hpricot-0.8.6.gem 293888 SHA256 dfe8f4b3414ba8377d7626030f3aa605caadee9de87cffbeadf8a50359eac8ca SHA512 f0ea9168ae79d099cdb751dd5a205e0896dfb229759e499fff833e94209d1497aa97becb285176dcbcc1fee19bc11913ca3ac0d7a467067e5d837c1eb6e310ad WHIRLPOOL d45ca1c1d8edfab43abcc0a14c3b035b9b9b934d95212ce61109692d83bbc641c34451b3dbd946fe9af7583628ab76eaeb097c909db5a182d2a86973b755ad4c
diff --git a/dev-ruby/hpricot/files/hpricot-0.8.6-fast_xs.patch b/dev-ruby/hpricot/files/hpricot-0.8.6-fast_xs.patch
new file mode 100644
index 000000000000..0b16b6c61b93
--- /dev/null
+++ b/dev-ruby/hpricot/files/hpricot-0.8.6-fast_xs.patch
@@ -0,0 +1,24 @@
+Index: hpricot-0.8.6/metadata
+===================================================================
+--- hpricot-0.8.6.orig/metadata
++++ hpricot-0.8.6/metadata
+@@ -16,7 +16,18 @@ bindir: bin
+ cert_chain: []
+
+ date: 2012-01-17 00:00:00 Z
+-dependencies: []
++dependencies:
++- !ruby/object:Gem::Dependency
++ name: fast_xs
++ prerelease: false
++ requirement: &id003 !ruby/object:Gem::Requirement
++ none: false
++ requirements:
++ - - ">="
++ - !ruby/object:Gem::Version
++ version: 0.7.3
++ type: :runtime
++ version_requirements: *id003
+
+ description: a swift, liberal HTML parser with a fantastic library
+ email: why@ruby-lang.org
diff --git a/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild b/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild
new file mode 100644
index 000000000000..5638722ea9c9
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.6-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby"
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rake-compiler"
+
+# dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
+USE_RUBY="${USE_RUBY/jruby/}" \
+ ruby_add_rdepend "dev-ruby/fast_xs"
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND+="
+ dev-util/ragel"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Fix encoding assumption of environment for Ruby 1.9.
+ # https://github.com/hpricot/hpricot/issues/52
+ # sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if RUBY_VERSION =~ /1.9/' test/load_files.rb || die
+}
+
+each_ruby_prepare() {
+ # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
+ [[ ${RUBY} == */jruby ]] && return
+
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${P}-fast_xs.patch
+ popd .. &>/dev/null
+}
+
+each_ruby_configure() {
+ # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
+ [[ ${RUBY} == */jruby ]] && return
+
+ ${RUBY} -Cext/hpricot_scan extconf.rb || die "hpricot_scan/extconf.rb failed"
+}
+
+each_ruby_compile() {
+ local modname=$(get_modname)
+
+ # dev-ruby/fast_xs does not cover JRuby so still bundle it here for now
+ if [[ ${RUBY} == */jruby ]]; then
+ ${RUBY} -S rake compile_java || die "rake compile_java failed"
+ return
+ fi
+
+ emake V=1 -Cext/hpricot_scan CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make hpricot_scan failed"
+ cp ext/hpricot_scan/hpricot_scan${modname} lib/ || die
+}
diff --git a/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild b/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild
new file mode 100644
index 000000000000..461207f2dee9
--- /dev/null
+++ b/dev-ruby/hpricot/hpricot-0.8.6-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A fast and liberal HTML parser for Ruby"
+HOMEPAGE="http://wiki.github.com/hpricot/hpricot"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "dev-ruby/rake
+ dev-ruby/rake-compiler"
+
+ruby_add_rdepend "dev-ruby/fast_xs"
+
+# Probably needs the same jdk as JRuby but I'm not sure how to express
+# that just yet.
+DEPEND+=" dev-util/ragel"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Fix encoding assumption of environment for Ruby 1.9.
+ # https://github.com/hpricot/hpricot/issues/52
+ # sed -i -e '1 iEncoding.default_external=Encoding::UTF_8 if RUBY_VERSION =~ /1.9/' test/load_files.rb || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/^REV/ s/.*/REV = "6"/' Rakefile || die
+}
+
+each_ruby_prepare() {
+ pushd .. &>/dev/null
+ epatch "${FILESDIR}"/${P}-fast_xs.patch
+ popd .. &>/dev/null
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/hpricot_scan extconf.rb || die "hpricot_scan/extconf.rb failed"
+}
+
+each_ruby_compile() {
+ local modname=$(get_modname)
+
+ emake V=1 -Cext/hpricot_scan CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "make hpricot_scan failed"
+ cp ext/hpricot_scan/hpricot_scan${modname} lib/ || die
+}
diff --git a/dev-ruby/hpricot/metadata.xml b/dev-ruby/hpricot/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/hpricot/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>