summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-08-27 11:22:29 +0200
committerHans de Graaff <graaff@gentoo.org>2022-08-27 11:23:18 +0200
commite09d2f1ed5089f7bda3bd7effa0e563ecabd8648 (patch)
tree56e54684997adb2571542e02a621da8048de6184 /dev-ruby/http_parser_rb
parentdev-libs/libgit2: Remove old (diff)
downloadgentoo-e09d2f1ed5089f7bda3bd7effa0e563ecabd8648.tar.gz
gentoo-e09d2f1ed5089f7bda3bd7effa0e563ecabd8648.tar.bz2
gentoo-e09d2f1ed5089f7bda3bd7effa0e563ecabd8648.zip
dev-ruby/http_parser_rb: add 0.8.0
Closes: https://bugs.gentoo.org/866950 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/Manifest1
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild29
-rw-r--r--dev-ruby/http_parser_rb/metadata.xml1
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/Manifest b/dev-ruby/http_parser_rb/Manifest
index 255fe0ce8758..91f97441ff0b 100644
--- a/dev-ruby/http_parser_rb/Manifest
+++ b/dev-ruby/http_parser_rb/Manifest
@@ -1 +1,2 @@
DIST http_parser.rb-0.6.0.gem 177664 BLAKE2B ecae9e862454584759cbb3158eb16dd6de09fe95c6b38099f1c6d4be2376ca1d3eb8a6713994da600c9c567193466da30f4784652e19ad796891a53d67578fff SHA512 51c29bfc85de8cedb4e98fec84c955252556abaa4d0848fbc38b232879ffc946c72acf38440e8e9f1e31a8b734a68d43a96924af5f48ac4f1a054153ec913a08
+DIST http_parser.rb-0.8.0.gem 195072 BLAKE2B e02fa70e5f5219d70c887db47541985b07f938bb32c4cca943a3d50f73e3baf820a733a2f479f5d40a2e1dabda4d8ae2466834c8b6d8167646a8fb6dcf7c792b SHA512 228e8a617154411c43a548f10d2d8d2cae2d97970f621b4ef2955de94ed1943611cff22659cd75d63a09a0a02396993ab646ee29303d99856b46a80253a618c8
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
new file mode 100644
index 000000000000..d00c5f9020cd
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.8.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_http_parser/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="https://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # rspec 3 compatibility
+ sed -i -e 's/be_true/be true/; s/be_false/be false/' spec/parser_spec.rb || die
+}
diff --git a/dev-ruby/http_parser_rb/metadata.xml b/dev-ruby/http_parser_rb/metadata.xml
index 28c8973fca91..9f78bfb37c79 100644
--- a/dev-ruby/http_parser_rb/metadata.xml
+++ b/dev-ruby/http_parser_rb/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<upstream>
<remote-id type="github">tmm1/http_parser.rb</remote-id>
+ <remote-id type="rubygems">http_parser.rb</remote-id>
</upstream>
</pkgmetadata>