summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-24 07:53:51 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-24 07:56:12 +0200
commite5d1e75bc58385c1bf648bd23272df417f1852a1 (patch)
treeddc8801aa4e06a573b2c621b2511a95f958ff92b /dev-ruby/http_parser_rb
parentdev-ruby/memoizable: EAPI 8; add ruby30 (diff)
downloadgentoo-e5d1e75bc58385c1bf648bd23272df417f1852a1.tar.gz
gentoo-e5d1e75bc58385c1bf648bd23272df417f1852a1.tar.bz2
gentoo-e5d1e75bc58385c1bf648bd23272df417f1852a1.zip
dev-ruby/http_parser_rb: EAPI 8; fix extension install
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/http_parser_rb')
-rw-r--r--dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
new file mode 100644
index 000000000000..ee71995c5020
--- /dev/null
+++ b/dev-ruby/http_parser_rb/http_parser_rb-0.6.0-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_NAME="http_parser.rb"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_http_parser/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple callback-based HTTP request/response parser"
+HOMEPAGE="https://github.com/tmm1/http_parser.rb"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""