summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-06 07:27:11 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-06 07:27:11 +0100
commitee2012d91e81760b179c4815bba837b8a77c1549 (patch)
treec40b21ee1004cdf888d33f2eaba1e39023a85fb1 /dev-ruby/httparty/httparty-0.16.4.ebuild
parentvirtual/pkgconfig-1: ppc64 stable (diff)
downloadgentoo-ee2012d91e81760b179c4815bba837b8a77c1549.tar.gz
gentoo-ee2012d91e81760b179c4815bba837b8a77c1549.tar.bz2
gentoo-ee2012d91e81760b179c4815bba837b8a77c1549.zip
dev-ruby/httparty: add 0.16.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/httparty/httparty-0.16.4.ebuild')
-rw-r--r--dev-ruby/httparty/httparty-0.16.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/httparty/httparty-0.16.4.ebuild b/dev-ruby/httparty/httparty-0.16.4.ebuild
new file mode 100644
index 000000000000..164c944481e5
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.16.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend 'dev-ruby/mime-types:3 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}