summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-13 06:35:47 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-13 06:35:47 +0200
commitb9fe990e7a330fa6f13d19d4b5e98839d39aa3dc (patch)
treee01af514bb15f40197d6600d0967b73d4c29c12c /dev-ruby/httpclient
parentdev-ruby/httpclient: cleanup (diff)
downloadgentoo-b9fe990e7a330fa6f13d19d4b5e98839d39aa3dc.tar.gz
gentoo-b9fe990e7a330fa6f13d19d4b5e98839d39aa3dc.tar.bz2
gentoo-b9fe990e7a330fa6f13d19d4b5e98839d39aa3dc.zip
dev-ruby/httpclient: add 2.8.2.4
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/Manifest1
-rw-r--r--dev-ruby/httpclient/httpclient-2.8.2.4.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index 675a14048ed0..c0189ad2d721 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -2,3 +2,4 @@ DIST httpclient-2.6.0.1.tgz 305847 SHA256 213f55639b85edf47fb32f865b59085a76d77c
DIST httpclient-2.7.1.tgz 457036 SHA256 d176c5177745d60434a05c3d85497f9a56c725aa6f9ee98ac14349f9ffe05cfc SHA512 960770fe351a82e4008ca706bc0f1c7ba255b67dcbcc2984b1f76b78bdb9236b799dbd81c98d706a6a3755677b8d11fe7d7dd5b3af6afaaf901d70d999a09ea2 WHIRLPOOL d6c70683f702c2b749d56ff011beb24e8b4d77acab6f587986e44ecd6a3c6ac73059b4080715b97b750d773c1c13bf4abcb91a0748087e233b0509b2592daa1d
DIST httpclient-2.8.1.tgz 458466 SHA256 a3852b8ecea14abc28c61fef734a473f7c7866c9d6853723165f91e69f9eb24b SHA512 3c90d741563047f5664d375b7228c94a7c6872b063feb01ae5820bb8e8794c92e59e660e239e9ea03a5fbee355771da13b8f1d8028f252e2d15424421a7e1230 WHIRLPOOL 92d74577d11b886aab52376d54cb94b058c26b354e551b738cc9cca5e8564ebe4af29d00227c52501faf26d3772af66d12323256830c49a84b492731a49893c0
DIST httpclient-2.8.2.2.tgz 460627 SHA256 4f2c3ae4db46737ad1ec09d1e0e5e8e70011a5ec9825352f1b3bbd01335b80ba SHA512 606b88934528a43b004c21a6f62ad3f3412b01f50c8e8e2cac634903ff5a248b95d1b2f29f3e7203b320836e4acbd2b7c115fd729af0faa0320ff96090089352 WHIRLPOOL 1d310f7b09cf203248137dd75693050ae02880aa5f0772089568fe488c7cbbed52b473e07aff3ff2387ce6019768c045722c93f6c8830f97136dfcc3b708f01c
+DIST httpclient-2.8.2.4.tgz 462907 SHA256 82c4a08d35f905a3031cdbdaaf838303cd90aaec7edfa12247c0f649c0dba397 SHA512 c225f302e6bd1f08fc089c202d4d870999ae9ef4bf1df416fb7f06b1732f50b9a7c69a5b73f1ee2f963665d5d436c243830555f8d42c60ac536abbae72b693a5 WHIRLPOOL 732c1c2ad18d47e0c424fc5922ab919f98e0df2e1f369ca43b212334f64944428caaafdaaee9b4f6e6952833282268d818f61211158579407074538faf7415cf
diff --git a/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild b/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild
new file mode 100644
index 000000000000..51d6422578df
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.8.2.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Fix documentation task
+ sed -i -e 's/README.txt/README.md/' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+
+ # Skip tests using rack-ntlm which is not packaged. Weirdly these
+ # only fail on jruby.
+ rm test/test_auth.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}